Users cannot obtain an account certificate for Rights Management Services (831657)



The information in this article applies to:

  • Microsoft Windows Rights Management Services (RMS) for Windows Server 2003

SYMPTOMS

A Microsoft Windows Rights Management Services (RMS) user may not be able to obtain a group identity certificate (GIC). When this problem occurs, he following event message appears in the application log in Event Viewer: Event Type: Error
Event Source: RMS
Event Category: Certification
Event ID: 139
Date: date
Time: time
User: N/A
Computer: computername
Description: The search of Active Directory failed. The following information was reported:
Microsoft.DigitalRightsManagement.Utilities.ADEntrySearchFailedException: Exception of type Microsoft.DigitalRightsManagement.Utilities.ADEntrySearchFailedException was thrown.
at
Microsoft.DigitalRightsManagement.Certification.Pipeline._GetPrincipalIdentifier(String principal, String desiredIdentifier)
at
Microsoft.DigitalRightsManagement.Certification.Pipeline._ProcessEmailAddress(IDrmsPropertyBag propertyBag, String& emailAddress, Identification identification) at Microsoft.DigitalRightsManagement.Certification.Pipeline.Certify(CertifyParams[] requestParams, HttpRequest request, IIdentity userIdentity).

CAUSE

This problem may occur if both the following conditions are true:
  • Your Active Directory directory services forest has more than one domain tree.
  • The RMS user resides in a domain tree other than the tree where the forest root domain is installed.
Directory Services cannot locate the user if the user belongs to a domain tree that is not the forest root domain.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Before you install this hotfix, you must remove any existing RMS installation. If the hotfix detects an existing RMS installation, it will prompt you to remove RMS. RMS saves its data and configuration settings in an SQL database, and this data is preserved during the reinstallation.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version   File name
   ------------------------------------------
   31-Oct-2003  12:21  1.0.3304  Drmsadir.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB831657 kbAudEndUser kbAudITPRO