Users receive a "service is not available" error message after you migrate from Microsoft Exchange 2000 Server Instant Messaging to Windows Messenger (830833)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

After you migrate from Microsoft Exchange 2000 Server Instant Messaging to Microsoft Windows Messenger, your users may receive the following error message in Windows Messenger when the users try to send an instant message:
The service is not available.

CAUSE

This issue may occur if the following conditions are true:
  • You do not delete the Exchange Instant Messaging virtual server in Exchange System Manager before you remove the Microsoft Exchange Instant Messaging Service.
  • A user does not manually click to clear the My contacts include users of Exchange Instant Messaging check box.
After a successful migration from Exchange 2000 Server Instant Messaging to Windows Messenger, the instant messaging client tries to connect to an Exchange server that is not running instant messaging.

RESOLUTION

To resolve this issue, follow these steps:
  1. Delete the Exchange Instant Messaging virtual server in Exchange System Manager. To do this, follow these steps:
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand the Administrative Groups container, and then expand the first administrative group.
    3. Click your server, and then double-click Protocols.
    4. Double-click Instant Messaging (RVP).
    5. In the Instant Messaging (RVP) pane, right-click the instant messaging virtual server, and then click Delete.
    6. Click OK.
    7. When the Exchange Instant Messaging virtual server is deleted, you must click No at the prompt to rehome users who have Exchange Instant Messaging enabled to another server.

      Note If you do not rehome these users to another server, the Exchange Instant Messaging attributes for each user are removed from the Active Directory directory service and are not orphaned in Active Directory.
  2. Remove the Microsoft Exchange Instant Messaging Service by using Add/Remove Programs in Control Panel. To do this, follow these steps:
    1. Click Start, point to Programs, and then click Control Panel.
    2. Double-click Add/Remove Programs.
    3. In the Currently installed programs list, click Microsoft Exchange 2000, and then click the Change or Remove button.
    4. Click Next.
    5. In the Action list for Microsoft Exchange 2000, click Change.
    6. In the Action list for Microsoft Exchange Instant Messaging Service, click Remove.
    7. Click Next.
    8. Click Next.
    9. Click Finish.
  3. Send your end users the following instructions to turn off their Exchange Instant Messaging account:
    1. Start the Exchange Instant Messaging client.
    2. Click Tools, click Options, and then click to clear the My contacts include users of Exchange Instant Messaging check box on the Accounts tab.

Modification Type:MajorLast Reviewed:3/2/2004
Keywords:kbRTC kbfix kbprb KB830833 kbAudITPRO