Link bar with custom links does not appear in SharePoint Portal Server 2003 or in SharePoint Services (830571)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Windows SharePoint Services
  • Microsoft Office FrontPage 2003

SYMPTOMS

When you view a Microsoft Office SharePoint Portal Server 2003 Web site or a Microsoft Windows SharePoint Services Web site, link bars with custom links do not appear as expected. Nothing appears where you expect to see the custom links.

CAUSE

This problem occurs when you do the following:
  1. You use Microsoft Office FrontPage 2003 to create a SharePoint site that contains a link bar with custom links. When you create a link bar with custom links, you click Create new on the General tab of the Link Bar Properties dialog box.
  2. In SharePoint Portal Server 2003 or in Windows SharePoint Services, you save the Web site that contains the link bar with custom links as a template.
  3. You create a new SharePoint Web site from the template that contains the link bar with custom links.
When you view the new SharePoint Web site that was created from the template, the link bar with custom links does not appear.

WORKAROUND

To work around this problem, you can use FrontPage 2003 to modify the link bar properties on the new SharePoint Web site to point to the link bar from the original Web site. To do so, follow these steps:
  1. Start Microsoft Office FrontPage 2003.
  2. On the File menu, click Open Site.
  3. Locate and then click the Web site that you want to modify.
  4. Click Open.
  5. Double-click the Web page that should contain the link bar with custom links. For example, double-click Default.aspx.
  6. Right-click the text [Edit the properties of this link bar to either rebuild it or choose a different link bar that already exists in this web.], which is displayed where you expect to see the link bar with the custom links, and then click Link Bar Properties.
  7. On the General tab, click the link bar that you want to add in the Choose existing list, and then click OK.
  8. On the File menu, click Save.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:9/8/2004
Keywords:kbWebServer kbBug KB830571 kbAudITPRO