Exchange database stores remain mounted although all transaction logs that are available to a storage group have been used (830408)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

SYMPTOMS

Users who have mailboxes in a particular storage group start to experience logon failures or other failures when they connect to their Microsoft Exchange 2000 Server mailboxes or Microsoft Exchange Server 2003 mailboxes. Although the store databases are still mounted, they become inaccessible.

Additionally, an event that is similar to the following is logged in the Application log: Event Type: Error
Event Source: MSExchangeIS Mailbox
Event Category: Logons
Event ID: 1022
Description: Logon Failure on database Path_of_Database.
Error: -519

CAUSE

This problem may occur if Exchange has used all the transaction logs that are available to a storage group. Exchange uses transaction log files that are numbered sequentially. The transaction log files start with Enn00001.log and then increment sequentially to Ennffff0.log, where nn is the number of the storage group. Storage groups are 00 through 03 because Exchange Server Enterprise Edition supports a maximum of four storage groups. Additionally, each storage group has a maximum of five information stores. The maximum number of transaction log files that can be generated in a single sequence is 1,048,560 (0xFFFF0). When the last transaction log is filled, the Microsoft Jet database engine returns error -519 (JET_errLogSequenceEnd) to the store. However, the store keeps the databases mounted although Jet transactions cannot occur.

RESOLUTION

Exchange 2000

Hotfix information

To resolve this problem, obtain the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup


This hotfix changes the existing Exchange behavior by causing the store databases to dismount when the Microsoft Jet database engine returns the -519 (JET_errLogSequenceEnd) error. This behavior helps Exchange administrators to quickly identify the problem storage group.

After you apply this hotfix, you still must manually resolve the problem that is described in the "Cause" section. See the "More Information" section for detailed information.

Another related hotfix for Exchange 2000 Server extends this behavior even more. Hotfix 896001 adds the following functionality. As the last available transaction log in the sequence draws near, an event that is similar to the following is logged in the Application log:Event Type: Warning
Event Source: ESE
Event Category: Logging/Recovery
Event ID: 514
Description: Information Store (2748) SG2: Log sequence numbers for this instance have almost been completely consumed. To begin renumbering from generation 1, the instance must be shutdown cleanly and all log files must be deleted. Backups will be invalidated. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

896001 An event is not logged in the Application log before the last available transaction log in the sequence is used in Exchange 2000 Server

Prerequisites

You must have Exchange 2000 Server Service Pack 3 (SP3) installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name
   -----------------------------------------------------------
   28-Oct-2003  04:17  6.0.6527.0   3,915,776  Cdoex.dll
   28-Oct-2003  04:12  6.0.6527.0     851,968  Davex.dll
   28-Oct-2003  04:12  6.0.6527.0      53,248  Davexpc.dll
   28-Oct-2003  04:08  6.0.6527.0     131,072  Drviis.dll
   28-Oct-2003  04:08  6.0.6527.0     577,536  Dsaccess.dll
   28-Oct-2003  03:18  6.0.6527.0     184,320  Dscmsg.dll
   28-Oct-2003  03:18  6.0.6527.0     962,560  Emsmdb32.dll
   28-Oct-2003  04:11  6.0.6527.0   2,179,072  Ese.dll
   28-Oct-2003  04:11  6.0.6527.0      40,960  Eseperf.dll
   09-Sep-2003  01:18                   6,991  Eseperf.hxx
   28-Oct-2003  04:11                 391,634  Eseperf.ini
   28-Oct-2003  04:17  6.0.6527.0   3,575,808  Excdo.dll
   28-Oct-2003  04:07  6.0.6527.0      90,112  Eximap4.dll
   28-Oct-2003  04:09  6.0.6527.0     262,144  Exmime.dll
   28-Oct-2003  02:57  6.0.6527.0     176,128  Exnntp.dll
   28-Oct-2003  04:12  6.0.6527.0     143,360  Exodbesh.dll
   28-Oct-2003  04:12  6.0.6527.0      57,344  Exodbpc.dll
   28-Oct-2003  04:12  6.0.6527.0     200,704  Exodbprx.dll
   28-Oct-2003  04:12  6.0.6527.0   2,179,072  Exoledb.dll
   28-Oct-2003  04:06  6.0.6527.0      81,920  Exosal.dll
   28-Oct-2003  04:08  6.0.6527.0      32,768  Expop3.dll
   28-Oct-2003  04:08  6.0.6527.0      32,768  Exproto.dll
   28-Oct-2003  04:12  6.0.6527.0     307,200  Exprox.dll
   28-Oct-2003  03:21  6.0.6527.0     143,360  Exschema.exe
   28-Oct-2003  04:12  6.0.6527.0     315,392  Exsmtp.dll
   28-Oct-2003  03:23  6.0.6527.0     675,840  Exwform.dll
   28-Oct-2003  02:58  6.0.6527.0     180,224  Exwin32.dll
   28-Oct-2003  03:21  6.0.6527.0      40,960  Febecfg.dll
   28-Oct-2003  04:08  6.0.6527.0      32,768  Iisif.dll
   28-Oct-2003  04:09  6.0.6527.0     135,168  Iisproto.dll
   28-Oct-2003  04:09  6.0.6527.0      61,440  Imap4be.dll
   28-Oct-2003  03:24  6.0.6527.0     319,488  Imap4evt.dll
   28-Oct-2003  03:22  6.0.6527.0     126,976  Imap4fe.dll
   28-Oct-2003  04:08  6.0.6527.0     126,976  Imap4svc.dll
   28-Oct-2003  04:09  6.0.6527.0      40,960  Jcb.dll
   28-Oct-2003  02:58  6.0.6527.0      49,152  Mdbevent.dll
   28-Oct-2003  03:15  6.0.6527.0   2,285,568  Mdbmsg.dll
   28-Oct-2003  03:00  6.0.6527.0      32,768  Mdbrole.dll
   28-Oct-2003  03:18  6.0.6527.0     909,312  Mdbsz.dll
   28-Oct-2003  04:09  6.0.6527.0      24,576  Mdbtask.dll
   28-Oct-2003  02:57  6.0.6527.0     151,552  Nntpex.dll
   28-Oct-2003  04:04  6.0.6527.0      94,208  Peexch50.dll
   28-Oct-2003  04:06  6.0.6527.0     397,312  Phatcat.dll
   28-Oct-2003  04:08  6.0.6527.0      36,864  Pop3be.dll
   28-Oct-2003  03:24  6.0.6527.0     303,104  Pop3evt.dll
   28-Oct-2003  03:23  6.0.6527.0      24,576  Pop3fe.dll
   28-Oct-2003  04:06  6.0.6527.0      73,728  Pop3svc.dll
   28-Oct-2003  03:24  6.0.6527.0     163,840  Protomsg.dll
   28-Oct-2003  04:09  6.0.6527.0     532,480  Reapi.dll
   28-Oct-2003  04:12  6.0.6527.0     311,296  Resvc.dll
   28-Oct-2003  04:07  6.0.6527.0   4,661,248  Store.exe
   28-Oct-2003  03:23  6.0.6527.0   3,735,552  Wmtemplates.dll

Exchange 2003

Exchange 2003 Service Pack 1 (SP1) includes the hotfix that is described in the "Hotfix information" section. Installing Exchange 2003 SP1 changes the existing Exchange behavior by causing the store databases to dismount when the Microsoft Jet database engine returns the -519 (JET_errLogSequenceEnd) error. This helps Exchange administrators to quickly identify the problem storage group.

After you install Exchange 2003 SP1, you still must manually resolve the problem that is described in the "Cause" section. See the "More Information" section for detailed information.

Besides causing the store databases to dismount when the Microsoft Jet database engine returns the -519 (JET_errLogSequenceEnd) error, Exchange 2003 SP2 also adds the following functionality. As the last available transaction log in the sequence draws near, an event that is similar to the following is logged in the Application log:Event Type: Warning
Event Source: ESE
Event Category: Logging/Recovery
Event ID: 514
Description: Information Store (2748) SG2: Log sequence numbers for this instance have almost been completely consumed. To begin renumbering from generation 1, the instance must be shutdown cleanly and all log files must be deleted. Backups will be invalidated.

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To reset the log file sequence, you must move all existing transaction logs to another location. After you do this, a new sequence of log files that starts with 0x00001 is generated.

Important Before you move the transaction logs, you must verify that all databases in the storage group are in a Clean Shutdown state.

To verify that all databases in the storage group are in a Clean Shutdown state, and to reset the log file sequence, follow these steps:
  1. Mark all the databases in the affected storage group to not mount on startup. To do this, follow these steps:
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand Organization, click Servers, click your server, click Information Store, and then click your storage group.
    3. Right-click your database, and then click Properties.
    4. Click the Database tab.
    5. Click to select the Don't mount this store at start-up check box.
  2. Kill the store because the database could not be dismounted.

    To download the latest version of the Debugging Tools for Windows package, visit the following Microsoft Web site:
  3. Restart the store so that other storage groups can be mounted.
  4. Run eseutil /r on all the databases that are in the affected storage group.
  5. Verify that the databases were in a Clean Shutdown state. To do this, follow these steps:
    1. In Exchange System Manager, right-click the first store in the storage group that has run out of transaction log files, and then click Properties.
    2. Click the Database tab, and then note the paths and the file names of the database files in the Exchange database box and in the Exchange streaming database box. Each Exchange database is composed of a paired set of files that have the .edb file name extension and the .stm file name extension. Repeat this step for each store in the storage group.
    3. At a command prompt, change the directory to the Exchange Server bin folder. For example, change the directory to C:\Program Files\Exchsrvr\bin.
    4. Type Eseutil /mh Database_File_Name, and then press ENTER.

      Repeat this step for each database in the storage group. This command displays the database file header. The header contains one of the following lines:
      • State: Clean Shutdown
      • State: Dirty Shutdown
  6. Move logs and checkpoint files to another location in case a recovery is required from an old database. The log files have the .log file name extension. The checkpoint files have the .chk file name extension.
  7. Mount all the databases in the storage group.
  8. Click to clear the Don't mount this store at start-up check box for all the databases in the affected storage group.
  9. The storage group will have to be backed up when delivery settles down on this computer because you cannot recover log files past the new log file generation point.
After you apply the hotfix for Exchange 2000 or install Exchange 2003 SP1, and you use the available transaction log files, if you try to mount the stores without performing these steps, events that are similar to the following may be logged in the Application log:Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 1159
Description: Database error 0xfffffdf9 occurred in function JTAB_BASE::EcEscrowUpdate while accessing the database "First Storage Group\Mailbox Store (SERVER)".Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9518
Description: Error 0xfffffddc starting Storage Group Path_of_Storage_Group on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed. For more information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/4/2006
Keywords:kbHotfixServer kbExchange2003sp1fix kbQFE kbfix kbExchange2000preSP4fix kbbug KB830408 kbAudITPRO