The X.400 connector does not add an entry to the message tracking log when you forward an e-mail message from Exchange 2000 Server to another mail server through an X.400 connector (830369)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

You receive a Simple Mail Transfer Protocol (SMTP) e-mail message from an external organization. When you forward the message from Microsoft Exchange 2000 Server to another mail server through an X.400 connector, the X.400 connector does not add an entry to the message tracking log.

CAUSE

The SMTP service uses the Request for Comments (RFC) 822 message ID to write the message tracking logs. However, the message transfer agent (MTA) service uses the message transfer system ID (MTS-ID) to write the message tracking logs. To relate the message tracking log entries with the RFC 822 message ID and with the MTS-ID, each entry can contain a linked message ID field.

In a pure SMTP submission, an MTS-ID is not added until the message is submitted to the Microsoft Exchange Information Store service for gateway delivery. Therefore, a link is not established in the message tracking logs. When the MTA service writes the message tracking logs for the outgoing X.400 transfer, the MTA service does not write the RFC 822 message ID in the linked message ID field.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Windows 2000 Service Pack 4 (SP4). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version      Size      File name
   -------------------------------------------------------
   14-Jul-2004   19:59   6.0.6611.0   331,776   Exsmtp.dll     

STATUS

Microsoft has confirmed that this is a problem in Exchange 2000 Server.

MORE INFORMATION

After you apply this hotfix, an MTS-ID is added before a message is submitted to the Microsoft Exchange Information Store service for gateway delivery. Therefore, the MTA service will write the RFC 822 message ID in the linked message ID field.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbexchCOEXISTMIGRATION kbfix kbExchange2000preSP4fix kbbug kbHotfixServer kbQFE kbpubtypekc KB830369 kbAudITPRO