You receive the "The target principal name is incorrect" error message when you try to start Active Directory Users and Computers in Windows 2000 (830069)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you try to start Active Directory Users and Computers, you may receive the following error message:
The target principal name is incorrect.
If you run the Dcdiag diagnostic tool, you may receive output that is similar to the following:

* Connecting to directory service on server <ServerName>.
[<ServerName>] LDAP bind failed with error 31.
A device attached to the system is not functioning.

CAUSE

This problem may occur when the security channel is broken. The security channel is a communication session that a computer uses to communicate with its domain controller.

RESOLUTION

To resolve this problem, follow these steps:
  1. At the command prompt, type nltest /SC_CHANGE_PWD:<DomainName>, and then press ENTER.

    Note Type the name of the domain where the computer account is kept instead of the <DomainName> placeholder.
  2. Type netdom reset <ComputerName> /domain:<DomainName>, and then press ENTER.

    Note Type the local computer name instead of the <ComputerName> placeholder. Type the name of the domain where the computer account is kept instead of the <DomainName> placeholder.
  3. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

REFERENCES

For additional information about resetting computer accounts, click the following article number to view the article in the Microsoft Knowledge Base:

216393 Resetting computer accounts in Windows 2000 and Windows XP

For additional information about the Dcdiag diagnostic tool, click the following article number to view the article in the Microsoft Knowledge Base:

265706 Dcdiag and Netdiag in Windows 2000 facilitate domain join and DC creation


Modification Type:MajorLast Reviewed:2/6/2004
Keywords:kbnofix kbwinservnetwork kbBug KB830069 kbAudITPRO