SYMPTOMS
When you configure the properties of a log file in the Microsoft Windows Server 2003 Performance tool to automatically create a new log file after a particular interval, the Performance Logs and Alerts service does not create the new log file at the interval that you specified.
Note To configure these settings, follow these steps:
- Start the Performance tool.
- Under Performance Logs and Alerts, click a log type.
- In the right pane, right-click a log file, and then click Properties.
- Click the Schedule tab, click After, and then click to select the Start a new log file check box.
CAUSE
This problem occurs if you configure the data sample interval with a value of greater than seven minutes. When you specify a sample interval of greater than seven minutes, a computational error occurs, and therefore the new log file is created at a random interval.
To view the sample interval settings, follow these steps:
- Start the Performance tool.
- Under Performance Logs and Alerts, click a log type.
- In the right pane, right-click a log file, and then click Properties.
- Click the General tab, and then view the options in the Sample data every list.
RESOLUTION
Hotfix Information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required.
Restart Requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003
Date Time Version Size File name
-----------------------------------------------------------
30-Sep-2003 21:27 5.2.3790.89 91,136 Smlogsvc.exe
Windows Server 2003 64-Bit Edition
Date Time Version Size File name
---------------------------------------------------------------------
30-Sep-2003 20:52 5.2.3790.89 214,016 Smlogsvc.exe IA-64
30-Sep-2003 21:27 5.2.3790.89 91,136 Wsmlogsvc.exe x86