Systems Management Server 2003 Software Metering Cannot Detect Applications That Are Slow to Initiate (829827)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

The Microsoft Systems Management Server 2003 Software Metering client agent cannot meter applications that run on a computer that has the Systems Management Server 2003 Advanced Client installed.

When this problem occurs, you may receive error messages that are similar to the following in the Software Metering Manager log file (Mtrmgr.log) that is located in the SMS_CCM\Logs folder on the Systems Management Server 2003 client computer: <![LOG[EnumProcessModules failed for process 4008, error 299]LOG]!><time="20:38:09.151+420" date="08-11-2003" component="mtrmgr" context="" type="3" thread="3956" file="processdata.cpp:102">
<![LOG[No usage will be tracked for process 4008, as failed to get owner info or executable file

CAUSE

This problem occurs if an application takes a long time to start on a computer that has the Systems Management Server 2003 Advanced Client installed. For example, if you run the application over a slow network link, the software metering client agent may not detect that the application has initialized.

The Software Metering client agent may not detect applications that take more than approximately 8 to 10 seconds to initialize. If the application process starts within 8 to 10 seconds, the application is metered regardless of whether the application's user interface takes longer than 8 to 10 seconds to appear.

The length of time that elapses before the Systems Management Server 2003 client agent stops trying to capture the application start event varies depending on the configuration of the client computer.

WORKAROUND

To work around this problem, you can configure the application to run on the local computer instead of over a slow network link.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kberrmsg kbnofix kbBug KB829827 kbAudITPRO