Windows logon dialog box is not available when you run the Super User utility (829640)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you try to log on to Microsoft Windows 2000 or to Microsoft Windows XP, the Log On to Windows dialog box may not be available.

CAUSE

This issue may occur when both of the following conditions are true:
  • Nobody is logged on to the local computer.
  • A scheduled job uses the Super User utility (Su.exe) to run under a user account.
When the Super User utility runs, it switches to the default desktop. When nobody is logged on, this action hides the Windows logon dialog box.

RESOLUTION

To resolve this issue, use one of the following methods:
  • Configure the Super User utility to run on its own desktop.

    For information about the options available with this utility, type su.exe /? at a command line, and then press ENTER.

    For example, to start the Super User utility on the default windowstation "winsta0" and on a new desktop "newdesktop", type the following command:

    su.exe User_Name cmd.exe Domain_Name winsta0\newdesktop

  • Reduce the screen saver wait time.

    When the screen saver appears, touch any key to dismiss it. The logon dialog box appears.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MajorLast Reviewed:2/4/2004
Keywords:kbpending kbBug KB829640 kbAudITPRO