Error Message: HTTP 502 Proxy Error - ISA Server Dial-Out Connection Failed (829621)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

On a Microsoft Small Business Server 2003-based computer, when you type a URL in Microsoft Internet Explorer to force an automatic dial-out of Microsoft Internet Security and Acceleration (ISA) Server 2000, your modem dials. However, it does not establish a connection to your Internet service provider (ISP). A dialog box appears in Internet Explorer that states that the page cannot be displayed, and you may receive the following error message:
HTTP 502 Proxy Error - ISA Server dial-out connection failed. The administrator should manually dial the specified phonebook entry to determine if the number can be reached (12207) Internet Security and Acceleration Server
If you click Network Connections in Control Panel, and you manually dial the specified phone book entry, you may receive the following error message:
Error 691: Access was denied because the username and/or password was invalid on the domain.

CAUSE

This behavior may occur if the user name or the password is incorrectly specified in either the network dial-up account or the dial-up connection.

This behavior may also occur if the default routing rule in ISA Server is configured to use a dial-up connection as the primary route for HTTP traffic and you are not using a dial-up connection to gain access to the Internet.

RESOLUTION

If You Use a Dial-up Connection

To resolve this behavior, use one of the following methods:

Method 1

Run the Change Dial-Up Connection Password wizard:
  1. Click Start, click Server Management, click Internet and E-Mail, and then click Change Dial-Up Connection Password.
  2. In the Dial-Up Connection dialog box, type your password for the dial-up connection in the Password box, and then type your password again in the Confirm Password box. Click OK.
  3. When the password change is confirmed, click OK.

Method 2

Run the Configure E-mail and Internet Connection Wizard:
  1. Click Start, click Server Management, click To Do List, and then click Connect to the Internet.
  2. On the Welcome to the Configure E-mail and Internet Connection Wizard page, click Next.
  3. On the Connection Type page, click Dial-up, and then click Next.
  4. On the Dial-up Connection page, type your password for the dial-up connection in the Password box, and then type your password again in the Confirm Password box. Click Next.
  5. Follow the instructions on the following pages to complete the Configure E-mail and Internet Connection Wizard.

If You Do Not Use a Dial-up Connection

If you are not using a dial-up connection to gain access to the Internet, use one of the following methods to change the default routing rule in ISA Server.

Method 1

Create a new connection to the Internet:
  1. Click Start, click Server Management, click To Do List, and then click Connect to the Internet.
  2. Follow the steps in the Configure E-mail and Internet Connection Wizard to set up the connection type that you are using.

Method 2

Make sure that a dial up-connection is not the primary route for HTTP traffic:
  1. Click Start, point to All Programs, point to Microsoft ISA Server, and then click ISA Management.
  2. Expand Servers and Arrays, expand Your Server Name, and then expand Network Configuration.

    Note Your Server Name is a placeholder for the name of your computer that is running ISA Server.
  3. Click Routing.
  4. In the right pane, right-click the appropriate routing rule, and then click Properties.
  5. Click the Action tab. Under Automatic dial-out, click to clear the Use Dial-up entry for primary route check box.

Modification Type:MajorLast Reviewed:11/19/2003
Keywords:kbprb KB829621 kbAudITPRO