When you try to install Microsoft CRM, you receive a "Failed to install Microsoft Customer Relationship Management Server" error message (829451)



The information in this article applies to:

  • Microsoft CRM 1.2
  • Microsoft Business Solutions CRM 1.0

SYMPTOMS

When you install Microsoft CRM, you may receive the following error message:
Failed to Install Microsoft Customer Relationship Management Server. Failed to Create Microsoft CRM Databases.
Or, you may receive the following error message:
Failed to Install Microsoft Customer Relationship Management Server. Setup was unable to grant access to the Microsoft CRM databases. Error 80040E14.

CAUSE

This problem may occur if one or more of the following events occurs:
  • Active Directory directory service replication does not replicate to all the domain controllers before the Microsoft CRM Setup program installs the Microsoft SQL Server users. The computer that is running Microsoft SQL Server may point to a domain controller that has not yet replicated the Microsoft CRM Active Directory container.
  • You are trying to install Microsoft CRM from a bad disk drive or from a bad disk.
  • If you are doing a complete reinstallation of Microsoft CRM, the .mdf and .ldf files that are associated with the Microsoft CRM SQL databases were not deleted.
  • The File Replication service or the Remote Procedure Call (RPC) service on the Microsoft CRM server is not started.
  • The Default Log Directory setting that is listed in the Microsoft SQL database setting is incorrect.
  • The Microsoft CRM server or the computer that is running Microsoft SQL Server is not correctly registered in Active Directory.

RESOLUTION

To resolve this problem, try the following resolutions in the order that they are presented. For example, follow the steps in Resolution 1, and if the problem is not resolved, go to Resolution 2.

Resolution 1: Force replication to all the other domain controllers immediately after the Microsoft CRM installation has installed any prerequisite programs

You do this when the installation is creating the organizational unit (OU) in Active Directory.

Note To resolve this behavior, use either of the following methods, depending on your environment and network policies.

Method A: Manually force replication

  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Sites and Services Manager.
  2. Expand the Sites folder, and then click the site that you will be replicating from.

    Note There should be at least one site that is named Default-First-Site-Name. This name may differ if you have manually configured additional sites.
  3. Expand Default-First-Site, or the appropriate folder, expand Servers, and then expand the Active Directory server name, where Active Directory server name is the actual name of the server.
  4. Click NTDS Settings. One or more objects are listed in the right pane. One of these objects is a link to the domain controller. To find the friendly names for the objects, right-click an object, and then view the name.
  5. Right-click the appropriate object, and then click Replicate Now.
    The replication occurs immediately. The network performance affects the time that is required to update the target domain controller.

Method B: Shut down all domain controllers except for the global catalog domain controller

Shut down all the domain controllers in the domain except for the domain controller that has the global catalog server. After the Microsoft CRM server installation is complete, restart the remaining domain controllers in the domain. The Microsoft CRM Active Directory organizational unit will replicate to the other domain controllers.

Resolution 2: Use a different disk drive, or a different installation disk

This error may be resolved by using a different disk drive. If you still receive one of the errors that is listed in the "Symptoms" section after you use a new disk drive, the first installation disk may be corrupted.

Resolution 3: Delete the .mdf and .ldf files that are associated with the Microsoft CRM databases

If you are completely reinstalling Microsoft CRM, remove the program by using the "Uninstall Steps" in "Appendix C" of the Microsoft CRM Implementation Guide. After Microsoft CRM has been removed, verify that the associated Microsoft SQL database files are deleted. Microsoft SQL database files have .mdf and .ldf extensions. To verify that the .mdf and .ldf files are removed, follow these steps:
  1. Locate the following folder:

    system drive:\Program Files\Microsoft SQL Server\MSSQL\Data

    In this path, system drive is the drive where you installed Microsoft SQL Server.
  2. Verify that the following .mdf and .ldf files that are associated with the Microsoft CRM databases have been deleted:
    • organization_name_METABASE.mdf
    • organization_name_METABASE.ldf
    • organization_name_MSCRM.mdf
    • organization_name_MSCRM.ldf
    • organization_name_CRYSTAL.mdf
    • organization_name_CRYSTAL.ldf
    In these file names, organization_name is the name of your company.

Resolution 4: Verify that the File Replication service and the Remote Procedure Call (RPC) service are running

Follow these steps to verify the status of the services:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Locate the File Replication and Remote Procedure Call services.
  3. Verify that the Startup Type values are set to Automatic and that both services are started.
  4. If the service is not started, right-click the service, and then click Start. Repeat this procedure at each server, and then re-try the installation of Microsoft CRM.

Resolution 5: Verify the "Default Log Directory" setting

  1. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
  2. Expand Microsoft SQL Servers, and then expand SQL Server Group.
  3. Right-click the Microsoft SQL Server instance where the Microsoft CRM databases are stored.
  4. Click the Database Settings tab.
  5. Verify that the Default Log Directory setting has the correct path of the Microsoft SQL Server log files.
  6. After the path is set correctly, restart the Microsoft CRM installation.

Resolution 6: Remove and re-add the Microsoft CRM server and the computer that is running Microsoft SQL Server to the domain

  1. Remove Microsoft CRM by following the directions in the Microsoft CRM Implementation Guide.
  2. Remove both the Microsoft CRM server and the computer that is running Microsoft SQL from the domain.
    1. Right-click My Computer and then click Properties.
    2. Click the Computer Name tab, and then click Change.
    3. Click the Workgroup option, and then type Workgroup as the name.
    4. Click OK.
    5. Restart the server and log on as the local administrator.
    6. Follow these steps for both the Microsoft CRM server and the computer that is running Microsoft SQL Server where the Microsoft CRM databases are stored.
  3. On the Active Directory server, click Start, point to Programs, point to Administrative Tools, click Users and Computers, and then click Computers.
  4. Delete the Microsoft CRM server and the computer that is running Microsoft SQL Server.
  5. Manually replicate the changes to any other domain controllers.
  6. Add the Microsoft CRM server and the computer that is running Microsoft SQL Server back to the domain.
    1. Right-click My Computer and then click Properties.
    2. Click the Computer Name tab, and then click Change.
    3. Click the Domain option, type the domain name that you are joining, and then click OK.
    4. Restart the server and log on to the domain.
  7. Reinstall Microsoft CRM.

REFERENCES

The Microsoft CRM Implementation Guide, Ig.pdf, is available on the Microsoft CRM documentation CD.

Modification Type:MinorLast Reviewed:8/19/2005
Keywords:kbMBSinstallation kberrmsg kbMBSMigrate kbprb KB829451 kbAudEndUser