Snapshots Do Not Work While Veritas Volume Manager Is Running After You Upgrade PSM 2.1 to PSM 2.2 (829441)



The information in this article applies to:

  • Persistent Storage Manager for Server Appliances
  • Microsoft Server Appliance Kit (SAK), version 2.01

SYMPTOMS

After you upgrade Persistent Storage Manager (PSM) from version 2.1 to version 2.2, and while you are running Veritas Volume Manager, you cannot take new PSM snapshots. Additionally, existing snapshots may be inaccessible.

CAUSE

This problem is caused by the way that PSM scans the unique ID name that is returned from the disk:
  • In PSM 2.1, the unique ID name was truncated at 16 characters.
  • In PSM 2.2, the whole 64-character limit is checked.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbprb KB829441 kbAudOEM kbAudDeveloper