Outlook Web Access receives a "page not found" error message in two frames of a Web page (829222)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you try to use Microsoft Outlook Web Access (OWA) to connect to a Microsoft Exchange 2000 Server computer, you see two frames in your Web browser window. Both frames may contain an error message that is similar to the following:
Page cannot be found.

CAUSE

This behavior may occur if you try to connect to a front-end Exchange 2000 computer that is behind a reverse proxy server.

This behavior occurs because the front-end Exchange 2000 computer sends the client's GET request by using Exprox.dll to the appropriate back-end Exchange computer. The content of the page is based on the host header that the back-end Exchange computer receives in the GET request, and the page is built by using Davex.dll. To the Web browser, the reverse proxy server appears to be the publishing Web server. Therefore, only one set of authentication headers are sent to authenticate the Web browser to the proxy server and to the publishing server. Because the reverse proxy server modifies the host header before it reaches the front-end Exchange 2000 computer, the contents of the OWA page are built incorrectly.

WORKAROUND

To work around this behavior, you must disable the reverse proxy server and pass the original host header that was typed in the client directly to the front-end Exchange 2000 computer. For more information about how to disable the reverse proxy server, see the documentation that is provided by the vendor of your proxy server.

MORE INFORMATION

For additional information about Microsoft Proxy Server 2.0, click the following article number to view the article in the Microsoft Knowledge Base:

198116 Authentication options and limitations using Proxy Server 2.0

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. For information about how to contact the vendor of your proxy server, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:1/12/2004
Keywords:kbprb KB829222 kbAudITPRO