A script that uses the RELOG command stops working when the log file size limit is reached in Windows Server 2003 (829200)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use the relog command in a script, the script does not work correctly in Microsoft Windows Server 2003. This problem occurs when the following conditions are true:
  • You use the relog command in a script to extract performance counters from performance counter logs and to copy the performance counters to a log file that you create.
  • You set a size limit on the log file that you create.
The script does not work correctly when the size limit is reached.

CAUSE

This problem occurs when the log file size limit is set to 100 megabytes (MB) or higher. The relog command cannot convert binary circular files that are larger than 100 MB.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version           Size     File name
--------------------------------------------------------------
23-Jun-2004  22:34  5.2.3790.186      573,952  Advapi32.dll  

WORKAROUND

To work around this problem, delete the log file before it reaches the 100 MB size limit. Or, set a size limit on the log file that is less than 100 MB.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB829200 kbAudITPRO