Setup fails and error messages are logged when you run Setup to install the RTM version of the server and client components for backward-compatible document libraries (827852)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

When you run Setup to install the Release to Manufacturing (RTM) version of the server and client components for backward-compatible document libraries on a Microsoft Office SharePoint Portal Server 2003 server where the Beta 2 Tech Refresh version of the client components for backward-compatible document libraries is already installed, Setup does not complete successfully. You receive the following error messages:
  • The following error message is logged to the Setup.log file:
    Component Name: SharePoint Portal Server Document Library Component
    Version: NA
    Installation Status: Failure
    Error Message: A fatal setup error has occurred. For details see <C:\Program Files\Microsoft Integration\Microsoft Office SharePoint Portal Server 2003 Doc Library\Logs\errorlog.txt>.
  • The following error message is logged to the Errorlog.txt file:
    SharePoint Portal Server Document Library Component: [0] CPkmSetupComponent::InstallMSIPackage, MSI Package (spsclisrv) setup failed with error code 0x80070666. Command=msiexec.exe. Args= /i "C:\Program Files\SharePoint Portal Server\Bin\spsclisrv.msi" /q /l*v "C:\Program Files\Microsoft Integration\Microsoft Office SharePoint Portal Server 2003 Doc Library\Logs\spsclisrv.Log" Reboot="ReallySuppress" ARPSYSTEMCOMPONENT=1 SERVERINSTALL=1

CAUSE

This problem occurs because you cannot install the RTM version of the server and client components for backward-compatible document libraries on a server where the Beta 2 Tech Refresh version of the client components for backward-compatible document libraries is already installed.

WORKAROUND

To work around this problem, follow these steps:
  1. Remove the Beta 2 Tech Refresh version of the client components for backward-compatible document libraries from the server. To do so, follow these steps:
    1. Click Start, point to Control Panel, and then click Add or Remove Programs.
    2. In the list of currently installed programs, click Client Components for Microsoft Office SharePoint Portal Server 2003, and then click Remove.
    3. When you are prompted to, click Yes.
  2. Repair the installation of SharePoint Portal Server on the server. To do so, follow these steps:
    1. In the Add or Remove Programs dialog box, in the list of currently installed programs, click Microsoft Office SharePoint Portal Server 2003, and then click Change.
    2. On the Welcome to the Microsoft Office SharePoint Portal Server 2003 Setup Wizard page, click Next.
    3. On the Maintenance Mode Options page, click Repair the server components of Microsoft Office SharePoint Portal Server 2003, and then click Next.
    4. When you are prompted, click OK.
To avoid this issue, remove the Beta 2 Tech Refresh version of the client components for backward-compatible document libraries from the server before you install the RTM version of the server and client components for backward-compatible document libraries on a server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For more information about the backward-compatible components for document libraries, see the "Managing Document Libraries" topic in the "Administration" section of the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:9/27/2006
Keywords:kberrmsg kbsetup kbnofix kbBug KB827852 kbAudITPRO