BizTalk Adapter for MQSeries quits unexpectedly if no default queue manager is selected (827816)



The information in this article applies to:

  • Microsoft BizTalk Adapter for MQSeries 1.0

SYMPTOMS

Your Microsoft BizTalk Adapter for MQSeries COM+ application may quit unexpectedly and you may receive an error message that is similar to the following in the system event log:
Component Prog ID: imagehlp.dll
Method Name: IDispenserDriver::Release Server
Application ID: {C15A1D2B-D2D2-44E8-94A3-56DD253A277D}
Server Application Name: BizTalk Adapter For MQSeries

The serious nature of this error has caused the process to terminate.
Exception: C0000005
Address: 0x0112001F
Call Stack: ,
+ 0x1120021 COMSVCS!DispManGetContext(unsigned long *,unsigned long *) + 0x164B

CAUSE

This problem may occur if no default queue manager is defined in IBM MQSeries Server.

RESOLUTION

To resolve this problem, define the default queue manager in MQSeries Server. To do this, follow these steps:
  1. Open the MQSeries Services Microsoft Management Console (MMC).
  2. Expand IBM MQSeries Services.
  3. Right-click a queue manager, and then click Properties.
  4. In the Properties dialog box, click the General tab.
  5. On the General tab, click to select the check box for Make this the default queue manager.

    Note You can make any queue manager the default queue manager.
  6. Restart the IBM MQSeries service.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/10/2004
Keywords:kberrmsg kbprb KB827816 kbAudDeveloper