Multiple certification authority messages appear during installation of Internet Explorer IEAK Redistribution (827082)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows XP

SYMPTOMS

When you use the Microsoft Internet Explorer Administration Kit (IEAK) to produce a redistribution of Internet Explorer Service Pack 1 (SP1), users who install the redistribution may receive an error message that is similar to the following error message in a Security Warning dialog box several times during the installation:
Do you want to install and run Internet Explorer Version signed on Date and time and distributed by:

distributor
The message reappears even though the redistribution is digitally signed and the users click Yes in the Security Warning dialog box.

Note The messages do not reappear if the user clicks to select the Always trust content from the provider check box.

CAUSE

This problem may occur with any digitally signed executable file that is signed by using a certificate that is not yet installed on a Windows XP-based computer. The problem occurs because Internet Explorer does not set the correct flag when the user clicks Yes in the Security Warning dialog box to trust the certificate.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   14-Aug-2003  18:52  6.0.2800.1247  190,464  Ie6wzd.exe

Installation information

To apply this hotfix, copy the Ie6wzd.exe file to the following IEAK program folder:

Program Files\IEAK6\iebin\en\optional

After the Ie6wzd.exe file has been copied, rebuild the redistribution of Internet Explorer SP1.

Note When you use the IEAK with this hotfix to produce a redistribution of Internet Explorer SP1, users continue to receive one message that is similar to the message that is described in the "Symptoms" section. However, users are no longer repeatedly prompted for authentication for the same executable file.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

Modification Type:MinorLast Reviewed:11/1/2005
Keywords:kbHotfixServer kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug KB827082 kbAudDeveloper