Backup Program Causes Gradually Declining Performance (826751)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use any third-party backup program on your Microsoft Windows Server 2003-based computer, you may experience one or both of the following symptoms:
  • Poor and gradually declining system performance
  • Out-of-memory errors

CAUSE

This problem occurs because of a memory leak in the code of the Volume Shadow Copy Service backup infrastructure.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Aug-2003  00:30  5.2.3790.79     1,339,392  Vssapi.dll       IA-64
   22-Aug-2003  00:27  5.2.3790.79       540,160  Wvssapi.dll      x86
   12-Aug-2003  18:54                        271  Branches.inf
   22-Aug-2003  01:23                     10,444  Kb826751.cat
   22-Aug-2003  00:48                        354  Updatebr.inf
   22-Aug-2003  00:48                      5,292  Update_rtmqfe.inf


 x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Aug-2003  22:34  5.2.3790.79       540,160  Vssapi.dll       
   12-Aug-2003  18:54                        271  Branches.inf
   22-Aug-2003  01:23                     10,091  Kb826751.cat
   22-Aug-2003  00:30                        354  Updatebr.inf
   22-Aug-2003  00:30                      5,027  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB826751 kbAudITPRO