SAC Client Console Is Not Updated Correctly When You Use the WMIC Command (826277)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use the Japanese version of Windows Server 2003 and you run the Windows Management Instrumentation Command-line (WMIC) wmic /? command from Special Administration Console (SAC), the SAC client console is not updated correctly, and no characters are returned.

CAUSE

This issue occurs because of how NULL characters are interpreted when you use SAC in the Japanese version of Windows Server 2003. (NULL characters are returned when you use the wmic /? command.) For SAC to return NULL characters correctly, the NULL characters must be represented as spaces.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   05-Aug-2003  00:28  5.2.3790.74        24,576  Sacsess.exe      x86
   04-Aug-2003  20:32  5.2.3790.74        77,824  Sacsess.exe      IA-64
  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about the SAC and SAC commands, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB826277 kbAudITPRO