BUG: You receive a COM+ error when you use .NET custom parsers with BizTalk Server 2002 (825818)



The information in this article applies to:

  • Microsoft BizTalk Server 2002

SYMPTOMS

If you use Microsoft .NET custom parsers with Microsoft BizTalk Server 2002, you may receive a Microsoft COM+ error message in the XLANG Scheduler application or in the BizTalk Server Interchange component that is similar to the following:

Event Type: Error
Event Source: COM+
Event Category: SVC
Event ID: 4194
Date: 15/07/2003
Time: 17:17:29
User: N/A
Computer: POLENZPATCH

Description: The system has called a custom component and that component has failed and generated an exception. This indicates a problem with the custom component. Notify the developer of this component that a failure has occurred and provide them with the information below.

Component Prog ID:
Server Application ID: {DFDE2592-40A4-42BC-A35E-FD0BF76CA4D5}
Server Application Name: XLANG Scheduler
Exception: C0000005
Address: 0x77AB1941
Call Stack: ,
ole32!CStdMarshal::DisconnectSrvIPIDs + 0xA8
ole32!CStdMarshal::Disconnect + 0x193
ole32!DisconnectSwitch+ 0x12
ole32!EnterForCallback + 0x6A
ole32!SwitchForCallbac + 0x12B
ole32!PerformCallback + 0x50
ole32!CStdMarshal::DisconnectAndRelease + 0x37
ole32!CRemoteUnknown::RundownOid + 0x196
RPCRT4!_Invoke@12 + 0x30
RPCRT4!_NdrStubCall2@16 + 0x655
RPCRT4!_CStdStubBuffer_Invoke@12 + 0xC8
Typically, this error causes the termination of schedule execution and of documents that are sent to the suspended queue.

CAUSE

The BizTalk Server 2002 custom parser interface was not originally designed to support Microsoft .NET custom parsers. This problem occurs because the CDataStream object that is passed to the managed custom parser component has a reference counting issue. Because of this issue, the CDataStream object is already deleted when garbage collection begins.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time    Version     Size     File name
   ------------------------------------------------------
   30-Jul-2003  00:00  3.0.1575.0  721,168  Cisparser.dll
				
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbQFE kbfix kbbug KB825818 kbAudDeveloper