SYMPTOMS
When you use the Msdmback.vbs script tool to restore SharePoint Portal Server, you may receive an error message similar to the following error message:
An error occurred while restoring the application. The application may be in an inoperable state.
Context: SharePointPortalServer Application
Details:
Object or data matching the name, range, or selection criteria was not found within the scope of this operation.
(0x80040e19)
When you receive this error message, you cannot restore SharePoint Portal Server.
CAUSE
This problem may occur when the Msdmback.vbs tool tries to restore a catalog for a workspace that does not exist in the backup. This problem may occur if the following conditions are true and occur in the order that they are presented:
- A workspace on the server is either not created correctly or is not deleted correctly.
- You use the Msdmback.vbs tool to back up the server.
- You use the Msdmback.vbs tool to restore the server.
When these conditions are true, the post-restoration operations for the workspace cannot be completed because the workspace does not exist in the backup. In this situation, when you restore SharePoint Portal Server data, the restore operation does not complete successfully for any workspaces.
RESOLUTION
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
---------------------------------------------------------
15-Jul-2003 18:00 10.145.6011.24 45,056 Pkmmsg.dll
15-Jul-2003 18:00 10.145.6011.24 380,928 Pkmpi.dll
Note Because of file dependencies, this update requires SharePoint Portal Server 2001 Service Pack 2 (SP2) or SharePoint Portal Server 2001 Service Pack 2a (SP2a).
After you apply this hotfix, the following event is logged to the Application event log to notify you when post-restoration operations for a workspace are not successful:
Type: Error
Event ID: 12801
Description:
Failed to perform the post-restoration steps for workspace WorkspaceName. The error returned was 0x80040e19
The Msdmback.vbs tool proceeds to restore the other workspaces to the server.