Domain Controller Loses Its Role as a Global Catalog Server (824139)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

A Windows Server 2003 domain controller under a heavy load (stress) may no longer recognize itself as a global catalog server. The Windows locator service returns the domain controller as a global catalog server, but the global catalog component no longer works.

CAUSE

This problem occurs because the TCP/IP driver (Tcpip.sys) leaks a packet during transmission in the firewall-processing fast-path over the loopback interface. This effectively disables loopback over IP, even though remote transmission is still processed correctly.

Under a heavy load, the domain controller may no longer be able to contact DNS. Because of this, the Net Logon service does not register correctly, and the domain controller loses its role as a global catalog server.

RESOLUTION

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately. To restart later, click to select the Do not restart now check box in the Windows Server 2003 Setup Wizard, and then click Finish.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Standard Edition, and Windows Server 2003, Enterprise Edition

Date         Time   Version            Size    File name
--------------------------------------------------------
01-Aug-2003  17:08  5.2.3790.74       334,336  Tcpip.sys

Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version            Size    File name
--------------------------------------------------------
01-Aug-2003  17:07  5.2.3790.74       969,728  Tcpip.sys

WORKAROUND

To work around this problem, restart the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB824139 kbAudITPRO