"The operating system image you selected does not contain the necessary drivers for your network adapter" error message during the text-mode part of Setup when you deploy an operating system image by using RIS (823658)



The information in this article applies to:

  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you deploy a Microsoft Windows Server 2003 image, a Microsoft Windows XP image, or a Microsoft Windows 2000 image from a Windows Server 2003-based Remote Installation Services (RIS) server or from a Windows 2000-based RIS server, the installation may fail during the text-mode part of Setup. You receive the following error message:

The operating system image you selected does not contain the necessary drivers for your network adapter. Try selecting a different operating system image. If the problem persists, contact your administrator. Setup cannot continue. Press any key to exit.

CAUSE

This problem may occur in situations when RIS does not recognize the syntax of the [Manufacturer] section of the .inf file for the network adapter driver. Therefore, Setup cannot locate the network driver.

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit editions

Date         Time   Version       Size     File name
-------------------------------------------------------
12-Dec-2003  01:52  5.2.3790.111  112,128  Binlsvc.dll

Windows Server 2003, 64-Bit Edition

Date         Time   Version       Size     File name     Platform
-----------------------------------------------------------------
12-Dec-2003  01:53  5.2.3790.111  286,720  Binlsvc.dll   IA-64
12-Dec-2003  01:52  5.2.3790.111  112,128  Wbinlsvc.dll  x86

Windows 2000 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version        Size    File name
-------------------------------------------------------
03-Sep-2003  22:02  5.0.2195.6815  97,552  Binlsvc.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For more information about RIS in Windows Server 2003, see the Windows Server 2003 Deployment Kit. To do so, visit the following Microsoft Web site: For more information about RIS in Windows 2000, visit the following Microsoft Web site:For additional information about how to install, configure, and troubleshoot RIS in Windows 2000, see the "Technical Guide to Remote Installation Services" white paper. To obtain this white paper, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:12/9/2005
Keywords:kbHotfixServer kbQFE kbWin2000preSP5fix kbBug kbfix kbQFE kbWinServ2003preSP1fix KB823658 kbAudITPRO