Memory-Dump Operation Does Not Complete on Computers with More Than 6 GB of RAM Installed (822998)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When Windows unexpectedly stops responding (hangs) and is configured to write debugging information to the Memory.dmp file, the memory-dump operation may not complete successfully. Additionally, you may experience one or both of the following symptoms:
  • The memory-dump operation stops responding when it is about 90-percent complete.
  • Windows does not automatically restart after the memory-dump operation stops responding.

CAUSE

This problem may occur if you have more than 6 gigabytes (GB) of random access memory (RAM) installed in the computer.

The memory-dump process stops responding in a large memory-dump operation because the ScsiPortGetPhysicalAddress() routine in the Diskdump.sys file returns a value of 0xcb000 instead of 0x1000cb000 to the miniport adapter driver.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately after installing this hotfix. If you want to restart later, click to select the Do not restart now check box in the Windows Server 2003 KB822998 Setup Wizard, and then click Finish.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version            Size    File name
-----------------------------------------------------------
23-Jun-2003  23:46  5.2.3790.66        17,920  Diskdump.sys

Windows Server 2003 64-Bit

Date         Time   Version            Size    File name
-----------------------------------------------------------
23-Jun-2003  23:46  5.2.3790.66        47,104  Diskdump.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This hotfix resolves this problem by using 64-bit arithmetic for the PHYSICAL_ADDRESS calculation.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB822998 kbAudITPRO