Cannot Read ISA Server Performance Data by Using an SNMP Program (822970)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000 SP1

SYMPTOMS

When you use a Simple Network Management Protocol (SNMP) program to read performance-related data from the Microsoft Internet Security and Acceleration (ISA) Server 2000 extension DLL files, you are unsuccessful. If you run the Snmputil.exe program to step through (walk) each ISA Server namespace, you receive a result that is similar to the following:

** bwcmib.dll **
MIB definition:
- OID: .15              .1
- NS: .bandwidthControl.bwcStatistics
SNMP Sample Response: SnmpExtensionInit() failed.
"snmputil walk" Response: End of MIB subtree.

The ISA Server SNMP components do not respond correctly. Either the namespace is not correctly resolved, or the DLL returns an "End of MIB" result.

CAUSE

This problem occurs because the following ISA Server 2000 SNMP management information bases (MIBs) do not load successfully:

Bwcmib.dll
Cachmib.dll
Hfmib.dll
Pfmib.dll
W3pmib.dll
Wspmib.dll

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next ISA Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version       Size   File name
----------------------------------------------------
10-Jul-2003  19:09  3.0.1200.282  6,928  Cachmib.dll

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Security and Acceleration Server 2000 SP1.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbQFE kbISAServ2000preSP2fix kbfix kbbug KB822970 kbAudITPRO