The File Signature Verification Tool in Windows XP Reports That Quartz.dll Is Unsigned (822879)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

SYMPTOMS

When you run the File Signature Verification tool (Sigverif.exe) in Microsoft Windows XP, you may find that the Quartz.dll file appears under The following files have not been digitally signed in the Signature Verification Results dialog box.

CAUSE

This problem may occur if the following conditions are true:
  • You install Microsoft Windows XP Service Pack 1 (SP1) on Windows XP Professional or on Windows XP Home Edition.

    -and-
  • You install Microsoft DirectX 9.0.

    -and-
  • You then upgrade DirectX 9.0 to version 9.0a.
Note This problem does not occur if you install DirectX 9.0a and not DirectX 9.0.

RESOLUTION

To resolve this problem, install the latest version of DirectX.

For more information about Microsoft DirectX, visit the following Microsoft DirectX Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
This problem was corrected in DirectX 9.0b.

MORE INFORMATION

To run the File Signature Verification tool, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type Sigverif.exe.
  3. Click OK.
For additional information about the Sigverif.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:

308514 HOW TO: Verify Unsigned Device Drivers in Windows XP


Modification Type:MajorLast Reviewed:10/30/2003
Keywords:kbprb KB822879 kbAudEndUser