Computer stops responding after you put it into hibernation, and then resume it from hibernation many times (822827)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you put your computer into an S4 sleep state (hibernation), and then resume it from hibernation many times, your computer may eventually stop responding (hang) before it enters hibernation. For example, the computer may stop responding after you put it into hibernation and then resume it from hibernation approximately 300 times.

CAUSE

This problem may occur if both the following conditions are true:
  • The Real Time Clock (RTC) wake-up feature is turned on.
  • You use the RTC wake-up feature to resume the computer from hibernation.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Information

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   26-Jun-2003  18:08  5.1.2600.1240     128,512  Halaacpi.dll     
   26-Jun-2003  18:08  5.1.2600.1240      78,208  Halacpi.dll      
   26-Jun-2003  18:08  5.1.2600.1240     130,688  Halmacpi.dll
   26-Jun-2003  18:34  5.1.2600.115      128,640  Halaacpi.dll     
   26-Jun-2003  18:34  5.1.2600.115       78,208  Halacpi.dll      
   26-Jun-2003  18:34  5.1.2600.115      130,816  Halmacpi.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For more information about Windows power management and Advanced Configuration and Power Interface (ACPI) power states, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB822827 kbAudITPRO kbAudEndUser