System Performance Decreases, and Many Event ID 576 Entries Are Logged to the Security Event Log (822774)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you configure an audit policy in Windows Server 2003, your system performance may decrease, and the server may become unresponsive. Additionally, when these symptoms occur, many Event ID 576 entries that are similar to the following are logged to the Security event log: Source: Security
Category: Privilege Use
Event ID: 576
Description:
Special privileges assigned to new logon:
User Name: UserName
Domain: Domain
Logon ID: Logon ID
Privileges: SeChangeNotifyPrivilege

CAUSE

This problem occurs because of too many audit events that are generated by the logging of the SeChangeNotifyPrivilege user right in Event 576. The load that is generated by the auditing of events that are related to the SeChangeNotifyPrivilege user right may affect system performance and cause the server to become unresponsive.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
----------------------------------------------------------------
11-Jun-2003  23:33  5.2.3790.54       738,816  Lsasrv.dll 
11-Jun-2003  23:26  5.2.3790.54     2,034,176  Lsasrv.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

After you apply the update that is documented in this article, the following user rights are audited by Event ID 576 and are logged to the Security event log:

SeAssignPrimaryTokenPrivilege
SeAuditPrivilege
SeBackupPrivilege
SeCreateTokenPrivilege
SeDebugPrivilege
SeEnableDelegationPrivilege
SeImpersonatePrivilege
SeLoadDriverPrivilege
SeMachineAccountPrivilege
SeRestorePrivilege
SeTakeOwnershipPrivilege
SeTcbPrivilege


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB822774 kbAudITPRO