"Outlook Web Access was unable to check the spelling on this item due to an error" error message when you use the spelling checker (822699)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you use the spelling checker to check an e-mail message in Outlook Web Access (OWA), you receive the following error message:
Outlook Web Access was unable to check the spelling on this item due to an error.

Additionally, events similar to the following may be logged in the system log in Windows Event Viewer: Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 36
User: N/A
Description: The description for Event ID ( 36 ) in Source ( W3SVC ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: /LM/W3SVC/1/root/ExchWeb/bin, The server process could not be started because the configured identity is incorrect. Check the username and password. Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10004
User: N/A
Description: DCOM got error "The referenced account is currently locked out and may not be logged on to." and was unable to logon .\IWAM_ABZTS111 in order to run the server: {3D14228D-FBE1-11D0-995D-00C04FD919C1}

CAUSE

This issue may occur if the passwords for the IWAM_ComputerName account or for the IUSR_ComputerName account are not synchronized with the Microsoft Internet Information Services (IIS) metabase and with the local accounts directory.

Note ComputerName is the name of the IIS computer.

RESOLUTION

To resolve this issue, reset the passwords for the IUSR and the IWAM accounts so that they are the same in both the Internet Information Services (IIS) metabase and in the local accounts directory. To do this, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Computer Management.
  2. Under System Tools, click Local Users and Groups, and then click Users.
  3. Right-click IUSR_ComputerName, and then click Set Password.
  4. Click Proceed.
  5. Type the password in the New password box and in the Confirm password box, and then click OK.
  6. Right-click IWAM_ComputerName, and then click Set Password.
  7. Click Proceed.
  8. Type the password in the New password box and in the Confirm password box, and then click OK.
  9. Quit Computer Management.
  10. Click Start, and then click Run.
  11. In the Open box, type cmd and then click OK.
  12. Type cd drive:\inetpub\adminscripts, where drive is the drive where Windows is installed, and then press ENTER.
  13. To reset the password for the IUSR_ComputerName account, type the following command (where password is the password that you set in step 5), and then press ENTER:

    cscript.exe adsutil.vbs set w3svc/anonymoususerpass "password"

  14. To reset the password for the IWAM_ComputerName account, type the following command (where password is the password that you set in step 8), and then press ENTER:

    cscript.exe adsutil.vbs set w3svc/wamuserpass "password"

  15. Update the starting identity of all IIS COM+ application packages by typing the following at the command prompt:

    cscript.exe synciwam.vbs -v

    Note You may need to restart IIS for all changes to take effect. To restart IIS, click Start, click Run, type iisreset, and then click OK.

MORE INFORMATION

For additional information about the Administration Script Utility (Adsutil.vbs) and about how to reset passwords, click the following article number to view the article in the Microsoft Knowledge Base:

297989 Configured identity is incorrect for IWAM account


Modification Type:MinorLast Reviewed:11/7/2005
Keywords:kbprb kberrmsg KB822699 kbAudITPRO