The MSMQ-MQSeries Bridge message pipes are in a pending state (822324)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1


Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The MSMQ-MQSeries Bridge message pipes are in a pending state, and one of the following messages is recorded in the event log.

Message 1

Source: MQBridge
EventID: 67
Type: Warning
MSMQ-MQSeries Bridge failed to start message pipe because
the MQSeries queue was in use.
QMngr     : QueueMgr
QName     : Queue.XMITQ
ACTION
No user intervention is required. Automatic recovery procedure will 
try to restart the message pipe.

Message 2

Source: MQBridge
EventID: 67
Type: Warning
MSMQ-MQSeries Bridge failed to start message pipe because
the MQSeries queue was in use.
QMngr     : QueueMgr
QName     : Queue.SYNC
ACTION
No user intervention is required. Automatic recovery procedure will 
try to restart the message pipe.

CAUSE

By default, the MSMQ-MQSeries Bridge tries to open MQSeries queues with exclusive access. This causes an "MQSeries queue was in use" event to be recorded in the event log. However, the MQSeries server acts as though the queues are already open, because the queues were never closed.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Jun-2003  14:26  5.64.0.854         37,136  Bcluster.exe     
   04-Jun-2003  14:26  5.64.0.854        340,240  Explres.dll      
   30-Apr-1999  15:16  1.28.0.0          144,197  Hotfix.exe       
   16-May-2003  16:25                      1,377  Hotfix.ini
   04-Jun-2003  14:26  5.64.0.854         65,808  Mqbinst.dll      
   01-Jan-2003  11:49                      4,608  Mqfrgnky.dll     
   04-Jun-2003  14:26  5.64.0.854        274,704  Q2qcldll.dll     
   04-Jun-2003  14:26  5.64.0.854        819,472  Q2qexpl.exe      
   04-Jun-2003  14:26  5.64.0.854        889,104  Q2qgw.exe        
   04-Jun-2003  14:26  5.64.0.854         33,040  Q2qmsg.dll       
   01-Jan-2003  11:49                      3,817  Q2qperf.ini
   04-Jun-2003  14:26  5.64.0.854        348,432  Q2qprfdl.dll     
   01-Jan-2003  11:49                        686  Q2qprfsm.def
   04-Jun-2003  14:26  5.64.0.854        327,952  Q2qshdll.dll     
   04-Jun-2003  14:26  5.64.0.854         41,232  Shdllres.dll     
   04-Jun-2003  14:26  5.64.0.854         90,384  Wmimqbridge.dll  
   01-Jan-2003  11:46                      6,403  Wmimqbridge.mof
                                             

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.You might be able to work around the network connectivity issues by opening the transmission queue and sync queue in shared mode. Use the appropriate registry settings, as follows.

Transmission queue in shared mode (Q2FO)

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MQBridge\Server\FalconCNS\YourForeignSite\Q2FO

  3. On the Edit menu, point to New, and then click STRING.
  4. Type SharedXMITQ, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type TRUE, and then click OK.

Transmission queue in shared mode (Q2FD)

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MQBridge\Server\FalconCNS\YourForeignSite\Q2FD

  3. On the Edit menu, point to New, and then click STRING.
  4. Type SharedXMITQ, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type TRUE, and then click OK.

Sync queue in shared mode

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MQBridge\Server\FalconCNS\YourForeignSite

  3. On the Edit menu, point to New, and then click STRING.
  4. Type SharedSyncQ, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type TRUE, and then click OK.

Microsoft Windows Server 2003

By default, this fix will not install on a Windows Server 2003-based computer. To work around this situation, follow these steps:
  1. Change two lines of code in the Hotfix.ini file. Change line a to read as shown in line b:
    1. Build = 2195
    2. Build = 3790
  2. When you install the hotfix, you can safely ignore the following error message:

    Hotfix: Error retrieving size of version information: 1813

    Although this error message means that the Mqfrgnky.dll dynamic-link library does not contain version information, you can install the hotfix.
  3. After the installation is complete, compare the files that came with the hotfix to the files in the following folder to verify the installation:

    C:\Program Files\Host Integration Server\System


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB822324 kbAudDeveloper