OL2000: Outlook Quits When Rule Searches for a Specific Word in the Subject or Body of Received Message (822312)



The information in this article applies to:

  • Microsoft Outlook 2000

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In Outlook 2000, when you have a rule that checks a received message for a specific word that is contained in the subject or body of the message, you may receive the following error message:
This program has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor.

CAUSE

This problem may occur if the following conditions are true:
  • The JunkEmail setting in the registry has been turned off.

    -and-
  • The Outlook rule searches the body of the e-mail message for the specific words.

RESOLUTION

How to Obtain the Hotfix

This issue is fixed in the Outlook 2000 Hotfix Rollup Package June 16, 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

822860 Availability of Outlook 2000 Post-Service Pack 3 Hotfix Rollup Package: June 16, 2003

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To work around this problem, change the JunkEmail setting in the Windows registry. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\JunkEmail

  4. With JunkEmail selected, click Modify on the Edit menu.
  5. In the Value data box, type zero ( 0), and then click OK.
  6. On the File menu, click Exit to quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbfix KB822312 kbAudEndUser