Internet Explorer Quits with Error in Shell64.dll When You Browse the Internet (822206)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows XP Home Edition SP1

SYMPTOMS

When you browse the Internet with Microsoft Internet Explorer 6.0, you may receive the following error message:
Microsoft Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.

If you were in the middle of something, the information you were working on might be lost.

Restart Internet Explorer

Please tell Microsoft about this problem

We have created an error report that you can send to help us improve Outlook Express. We will treat this report as confidential and anonymous.
When you click to view the details of the error message, you receive an error signature similar to the following:
   AppName       AppVer         ModName      ModVer   Offset
   -----------------------------------------------------------
   Iexplore.exe  6.0.2800.1106  Shell64.dll  1.0.1.6  000066b7

CAUSE

This problem may occur if an unknown third-party add-in on your computer installed Shell64.dll on your computer.

WORKAROUND

To work around this problem, unregister the Shell64.dll file, and then rename the file. To do this, follow these steps:
  1. Quit Microsoft Internet Explorer.
  2. Click Start, and then click Search.
  3. Click All Files and Folders.
  4. In the All or part of the file name box, type Shell64.dll, change the Look in box to your hard disk, and then click Search.
  5. If you locate the Shell64.dll file, note its location of the file.

    By default, its location is C:\Windows\System32, but its location may be different on your computer. Do not close the Search Results window.
  6. Click Start, and then click Run.
  7. In the Open box, type Regsvr32 /u, followed by the location of the Shell64.dll file you found in step 5, and then click OK.

    For example, type:

    Regsvr32 /u "C:\Windows\System32\Shell64.dll"

  8. When you are prompted to acknowledge that the program succeeded, click OK.
  9. Switch to the Search Results window.
  10. Right-click the Shell64.dll file, and then click Rename.
  11. Type a file name, and then press ENTER.

    For example, type:

    Shell64.old

    .
  12. Close the Search Results window.

STATUS

Microsoft has confirmed that this is a problem in an unknown third-party add-in in Internet Explorer.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/3/2004
Keywords:kbprb KB822206