FIX: A program cannot re-establish communication with a modem device after the USB cable is quickly reconnected (822112)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional

SYMPTOMS

After you disconnect and quickly reconnect a universal serial bus (USB) cable, a program cannot re-establish communication with the USB modem device. This behavior describes the typical symptoms. The exact symptoms that you experience depend on the program that you are using.

CAUSE

This problem occurs because of an issue with the Unimdm.tsp file.

RESOLUTION

Microsoft Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   30-May-2003  14:59  5.1.2600.1228  190,464  Unimdm.tsp

Microsoft Windows 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   16-Jun-2003  17:23  5.0.2195.6756  206,096  Unimdm.tsp
   16-Jun-2003  17:23  5.0.2195.6756   14,608  Uniplat.dll

WORKAROUND

To work around this problem, quit the program, disconnect the USB cable from the modem device for 10 seconds, and then reconnect the USB cable to the modem device. You can expect the program to re-establish communication with the modem device.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the behavior

To reproduce the behavior, use any modem class driver and a program that uses Telephony Application Programming Interface (TAPI). For example, if you use a dial-up network or if you use remote access, follow these steps:
  1. Click Start, click My Computer, click My Network Places, and then click View network connections.
  2. Click Create a new connection, and then follow the prompts in the New Connection Wizard. Click Next on each page of the wizard.
  3. Click Connect to the network at my workplace. By default, Dial-up connection is selected.
  4. Type Temp in the Company Name box.
  5. Enter a phone number for the system to dial.
  6. Make the connection available for anyone's use.
  7. After you finish the wizard, dial the Temp connection.
  8. While the system is connecting, disconnect and reconnect the USB cable within three seconds. You receive the following error message:Error 651: The modem (or other connecting device) has reported an error.
  9. Cancel the Temp connection, and then double-click the Temp connection.
  10. Dial the Temp connection. You receive the following error message:
    Error 633: The modem (or other connecting device) is already in use or is not configured properly.
    You can repeatedly cancel and dial the Temp connection.
After you install the update that is mentioned in the "Resolution" section, the program might take 10 seconds to re-establish a connection to the USB modem device.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbBug kbDDK kbnetwork kbPlugPlay kbUSB kbfix KB822112 kbAudDeveloper kbAudEndUser