Messages are not delivered and NDRs are incorrectly generated when you send a message to many recipients in Exchange Server 2003 on a Windows Server 2003-based system (822105)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

If you are running Microsoft Exchange Server 2003 on a Microsoft Windows Server 2003-based computer, and Exchange Server processes a message that has many recipients, the message is delivered to only some of the intended recipients. Exchange Server generates non-delivery reports (NDRs) for the other recipients. This issue occurs even if you resend the message.

CAUSE

This problem may occur if the following conditions are true:
  • The Simple Mail Transfer Protocol (SMTP) service in Windows Server 2003 uses pipelining to send a message that has many different recipients to another Exchange server that supports pipelining.

    Note By default, pipelining is used when Exchange servers communicate with other Exchange servers.
  • The number of recipients that is specified in the message exceeds the maximum recipient limit that is specified on the receiving Exchange server.
In this scenario, the SMTP service incorrectly tracks the number of recipients who receive the "error 552" error message. This error message indicates that the maximum number of recipients on the receiving Exchange server has been exceeded. Therefore, NDRs are incorrectly generated for some of the recipients of the message.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
Date         Time   Version      Size     File name
-----------------------------------------------------
02-Jun-2003  09:57  6.0.3790.47  456,192  Smtpsvc.dll  
Windows Server 2003, 64-Bit Edition
Date         Time   Version      Size       File name
-------------------------------------------------------------
02-Jun-2003  09:17  6.0.3790.47  1,174,528  Smtpsvc.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB822105 kbAudITPRO