PostScript fonts that are not valid are incorrectly installed when you use Control Panel Fonts in Windows XP (822084)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you manually install PostScript fonts by using the Fonts item in Control Panel, fonts that are not valid or that are malformed are incorrectly installed. You expect that a font that is not valid will be rejected. Later, you may receive error messages if the PostScript fonts that you installed are not valid.

Note If you call the AddFontResource function directly, the font is rejected as expected.

CAUSE

This problem occurs because a logic error occurs in Fonts during the font validity check. Although all fonts are checked, the check process does not work correctly on certain fonts that are not valid. An error condition is ignored.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 
   Date         Time    Version          Size      File name
   --------------------------------------------------------------
   29-May-2003  11:33   5.1.2600.1228    361,984   Fontext.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbDownload kbWinXPpreSP2fix kbfix kbbug KB822084 kbAudITPRO