Error message when you try to install an Internet Explorer security patch, update, or hotfix package: "This update requires Internet Explorer" (821484)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows XP
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP SP1
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0 SP6a
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 SP2, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0 SP6a
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 SP4, when used with:
    • the operating system: Microsoft Windows 2000 SP4
  • Microsoft Internet Explorer 5.01 SP3, when used with:
    • the operating system: Microsoft Windows 2000 SP3

SYMPTOMS

When you try to install an Internet Explorer update (for example, a security patch or a hotfix package), you may receive the following error message, where version is the version of Internet Explorer with which the update package was designed to be used:
Microsoft Internet Explorer Update

This update requires Internet Explorer version to be installed.

CAUSE

This error may occur for any of the following reasons:
  • You try to install the wrong version of the update. Internet Explorer updates are specific to the version of Internet Explorer that you are running (including service pack level and any hotfixes). For example, you must not install an update that is for Internet Explorer 6.0 on a computer that is running Internet Explorer 5.5 or Internet Explorer 6.0 Service Pack 1 (SP1).
  • You try to install the wrong localized version of the update for your operating system language locale. For example, you try to install an English update on a computer that is running a German version of Windows and Internet Explorer.
  • You use Multilingual Menus and Dialog Boxes for Internet Explorer, Multilingual Menus and Dialog Boxes for Windows 2000, Multilingual Menus and Dialog Boxes for Windows XP Professional, or Multilingual Menus and Dialog Boxes for Windows Server 2003, and your input language is set to a different language than your default operating system language. For example, you try to install an English update on an English version of Windows XP Professional and your default input language is set to German.
  • The update that you are trying to install contains one or more files that have an earlier version number than the files that are already installed on your computer. This problem may occur if you have already installed a later update than the update that you are trying to install. In this case, you may have to remove the later update, install the update that is blocked, and then reinstall the later update.

RESOLUTION

To resolve this issue, follow these steps:
  1. Verify that you have the correct version of the update for the version of Internet Explorer that you are using. For example, verify that you are not trying to install an Internet Explorer 5.01, Internet Explorer 5.5, or Internet Explorer 6.0 update on a computer that is running Internet Explorer 6.0 SP1.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    164539 How to determine which version of Internet Explorer is installed



    Note To confirm that you have the correct version of the update package, use the /c /t:Dir switches to extract the update package, and then compare the version number of the files in the package to your version of Shdocvw.dll. To extract the update package, type the following at the command prompt, and then click ENTER, where number is the Microsoft Knowledge Base article that documents the patch, and Dir is the folder where you want to extract the files in the patch:

    Qnumber /c /t:Dir


    Compare the versions of the files that you extracted to your version of the Shdocvw.dll file. If the files from the update package are later version numbers than the version number of your Shdocvw.dll file, but are earlier version numbers than the next version of Internet Explorer (from the Microsoft Knowledge Base article that is listed earlier in step 1), you have the correct version of the update.
  2. Verify that you have the correct localized version of the update for your operating system language. For example, if you are running an English version of Windows and Internet Explorer, verify that you have the English version of the update.
  3. If you use Multilingual Menus and Dialog Boxes for Internet Explorer, Multilingual Menus and Dialog Boxes for Windows 2000, Multilingual Menus and Dialog Boxes for Windows XP Professional, or Multilingual Menus and Dialog Boxes for Windows Server 2003, and your input language is set to a different language than your default operating system language, temporarily change your input language to the same language as the update and your operating system. To do this, click the language indicator in the system notification area of your taskbar, and then click the two-letter abbreviation for the appropriate language.
  4. If you have already installed a later update that is not included in the update you are trying to install, follow these steps:
    1. Compare the version numbers for the files that are included in the update that you are trying to install with the version of those files that are already installed on your computer. The file information for the update that you are trying to install is documented in the Microsoft Knowledge Base article or in the Microsoft Security Bulletin that is associated with the update.
    2. If all the files on your computer have a version number that is later than the version numbers of the files that are included with the update that you are trying to install, you do not have to install the update. All software updates for Internet Explorer are cumulative.

      However, if one or more of the files on your computer have a version number that is the same or earlier than the version numbers for the files that are included in the update that you are trying to install, you must remove these files.

      Search the Microsoft Knowledge Base or Microsoft Security Bulletins for the update that includes the files that have the same version numbers for the files that are already installed, and then remove this update.
    3. Install the update that is blocked.
    4. Reinstall the later update.

Modification Type:MinorLast Reviewed:4/17/2006
Keywords:kberrmsg kbprb kbinfo KB821484 kbAudDeveloper kbAudEndUser