Programs that are advertised to a user run when another user logs on to an SMS 2.0 client computer (821451)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

Programs that you advertise to a user in Microsoft Systems Management Server (SMS) 2.0 may run when a different user logs on to the computer. For example, you create a series of packages, Package A through Package H. You advertise Package A through Package F to user1. You advertise Package G and Package H to user2. User1 logs on to the computer and starts Package A, but logs off the computer before Package B starts. User2 logs on to the same computer. Package G and Package H run as expected. However Package B through Package F also run, although user2 is targeted to only receive Package G and Package H.

CAUSE

This problem occurs because user-specific packages are not removed from the execution list when a log on event or a log off event occurs. If programs are scheduled to run and the job files are in the \Ms\Sms\Clicomp\Apa\Jobs folder on the client, the packages are run. This problem occurs although a different user who is not in the targeted collection logs on to the computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2.0 Service Pack 5 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------------
   25-Feb-2003  06:35  2.0.1493.5140     238,944  Abnwcli.dll
   25-Feb-2003  12:45  2.0.92.10         383,678  Apasetup.exe
   25-Feb-2003  06:35  2.0.1493.5140     263,008  Bindclin.dll
   25-Feb-2003  12:40  2.0.92.10       1,377,876  Ccmcore.exe
   25-Feb-2003  12:40  2.0.1493.5177   3,498,252  Clicore.exe
   25-Feb-2003  06:55  2.0.1493.5144      90,480  Clisvcl.exe
   25-Feb-2003  12:45                         67  Compverbase.ini
   25-Feb-2003  12:45                         67  Compversmsapm32.ini
   25-Feb-2003  12:45                         67  Compverswdist.ini
   25-Feb-2003  06:15  2.0.1493.5136      35,168  Cqmgr32.dll
   25-Feb-2003  06:35  2.0.1493.5140     161,120  Falclin.dll
   25-Feb-2003  06:35  2.0.1493.5140     340,832  Mslmclin.dll
   25-Feb-2003  06:35  2.0.1493.5140     272,736  Ndsclin.dll
   05-Aug-2000  23:51  2000.80.194.0     274,489  Ntwdblib.dll
   25-Feb-2003  07:10  2.0.1493.5147      54,640  Odpsys32.exe
   25-Feb-2003  07:10  2.0.1493.5147      60,784  Odpusr32.exe
   23-Feb-2003  00:05  2.0.1493.5011     855,312  Preinst.exe
   25-Feb-2003  12:45  2.0.1493.5181     258,928  Smsapm32.exe
   25-Feb-2003  07:10  2.0.92.10         641,211  Swdist32.exe
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

How to Install the Hotfix

Hotfix installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms20-sp5-kb821451-x86-enu.exe update file to the new folder.
  3. From each primary and secondary SMS site server in your environment, log on to the site server by using an account with administrative credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms20-sp5-kb821451-x86-enu.exe, and then follow the instructions on the screen.

Manual installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Run Sms20-sp5-kb821451-x86-enu.exe, and then extract the hotfix files to the folder that you created in step 1.
  3. From each primary and secondary SMS site server in your environment, log on to the site server by using an account with administrative credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Click Start, point to Administrative Tools, and then click Services.
  6. Stop all SMS services.
  7. Replace the following files in the \SMS\Bin\I386 folder with the versions from the hotfix:
    • Abnwcli.dll
    • Bindclin.dll
    • Clisvcl.exe
    • Cqmgr32.dll
    • Falclin.dll
    • Mslmclin.dll
    • Ndsclin.dll
    • Ntwdblib.dll
    • Odpsys32.exe
    • Odpusr32.exe
    • Smsapm32.exe
  8. Replace the Swdist32.exe file in the \SMS\Inboxes\Clicomp.src\SWDist\I386 folder with the version from the hotfix.
  9. Replace the Apasetup.exe file in the \SMS\Inboxes\Clicomp.src\Smsapm32\I386 folder with the version from the hotfix.
  10. Replace the Ccmcore.exe and Clicore.exe files in the \SMS\Inboxes\Clicomp.src\Base\I386 folder with the versions from the hotfix.
  11. Replace the Compver.ini file in the \SMS\Inboxes\Clicomp.src\SWDist folder with the Compverswdist.ini file from the hotfix.

    Note You must rename the Compverswdist.ini file to Compver.ini.
  12. Replace the Compver.ini file in the \SMS\Inboxes\Clicomp.src\Smsapm32 folder with the Compversmsapm32.ini file from the hotfix.

    Note You must rename the Compversmsapm32.ini file to Compver.ini.
  13. Replace the Compver.ini file in the \SMS\Inboxes\Clicomp.src\Base folder with the Compverbase.ini file from the hotfix.

    Note You must rename the Compverbase.ini file to Compver.ini.
  14. Restart the SMS Services
  15. Perform a site reset. To do this, follow these steps:
    1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Setup.
    2. Click Next, click Next, and then click Modify or reset the current installation.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbAdvertisement kbPackage kbCollections kbClient kbSMSAppMan kbSMS200SP6fix kbSMS200preSP6fix kblogin kbUser kbSoftwareDist kbfix kbbug KB821451 kbAudITPRO