"Problem Getting Input Info" Error Message When You Try to Run the DirectX Diagnostic Tool (817858)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you try to run the DirectX Diagnostic Tool (Dxdiag.exe), you may receive the following error message:
Error: Problem getting input info, result code = 0x80004005 (Generic Failure)

CAUSE

This problem may occur when you upgrade to Microsoft DirectX 9.0 on a Gateway computer that has LANDesk Client Manager installed.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

WORKAROUND

To work around this problem, install the Administrator (multinode console) version of LANDesk Client Manager.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For more information about DirectX, visit the following Microsoft Web site: For more information about Gateway computers, visit the following Gateway Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/25/2004
Keywords:ATdownload kbWinXPsp2fix kberrmsg kbpending kbWinXPpreSP2fix kbfix kbbug KB817858 kbAudEndUser kbAudITPRO