You are continuously prompted to restart the computer to remove pending files during a SQL Server service pack installation on a computer that is running SMS 2.0 (817362)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

When you try to install a Microsoft SQL Server service pack on a computer that has Microsoft Systems Management Server (SMS) 2.0 installed, you may be prompted to restart the computer to remove pending files. The message may appear although no other file operations are active, and it may appear after you restart the computer.

CAUSE

This problem may occur if more than one SMS 2.0 remote administrative console submits a site property change (an .sca file) at the same time. If the Data Discovery Manager (DDM) component cannot delete the SCA file, DDM assumes that the file is locked by a process. Therefore, DDM places the file name in the registry to be deleted when the computer is restarted. The file name is stored in the PendingFileRenameOperations entry in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager registry subkey. Setup programs may detect this registry entry and then prompt to restart the computer to clear pending file operations before the installation can continue.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS Service Pack 5 (SP5) installed to apply this hotfix.

Restart requirement

You must stop the SMS Executive service to apply this hotfix and then restart it.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version  Size     File name
   ---------------------------------------------------------------------
   17-Apr-2003  19:46  2.0.4.1  252,645  Sms2.0-kb817362-sp5-x86-enu.exe
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version        Size     File name    Platform
   -----------------------------------------------------------------
   25-Feb-2003  14:45  2.0.1493.5117  261,904  Ddm.dll      Alpha
   25-Feb-2003  14:45  2.0.1493.5117  173,456  Ddm.dll      x86
   23-Feb-2003  10:05  2.0.1493.5011  855,312  Preinst.exe  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbRegistry kbSMS200preSP6fix kbUpgrade kbsetup kbinterop kbfix kbBug KB817362 kbAudITPRO