OnePoint Service Exhausts the Processor When It Monitors the Internet Information Server Logs (816965)



The information in this article applies to:

  • Microsoft Operations Manager 2000

SYMPTOMS

When Microsoft Operations Manager (MOM) 2000 is configured to monitor Internet Information Server (IIS) log files, the monitoring agent may exhaust the processor on the computer that it monitors.

CAUSE

This problem may occur if the MOM Application Log Event Provider component tries to process a file that is zero bytes.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next MOM 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, the following conditions must be true:
  • You must have MOM 2000 Service Pack 1 (SP1) installed on the computer.
  • The MOM server computer hosts a Microsoft Operations Manager Consolidator (CAM).
  • The MOM server computer hosts a manually installed MOM agent service.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version  Size       File name
   ---------------------------------------------------
   25-Jun-2003  16:47  1.0.0.0  1,178,672  Q816965.exe
After the fix is installed, the following file will have the listed attributes or later:
   Date         Time   Version     Size     File name
   --------------------------------------------------------------
   24-Jun-2003  20:37  4.0.1300.7  389,185  Eemapplogprovider.dll

WORKAROUND

To work around this problem, delete the 0-byte files. To do this, follow these steps:
  1. On the computer where the monitoring agent exhausts the processor, click Start, point to Programs, and then click Administrative Tools.
  2. Double-click Services.
  3. Stop the OnePoint service.
  4. Click Start, point to Search, and then click For Files or Folders...
  5. Click Search Options >>.
  6. Click to select the Size check box, and then click at most in the drop-down menu.
  7. In the KB field, type:

    0

  8. Click Search Now.
  9. In the Search Results list, delete any 0-byte files that are in the folder that contains the log files that MOM is monitoring.
  10. Start the OnePoint service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbBug KB816965 kbAudEndUser