Roaming profiles may not unload after you use WMI on a Windows Server 2003-based computer or a Windows XP-based computer (816880)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you log off a Roaming Profile User account, the logoff process may take longer than expected to complete.

CAUSE

When you enumerate certain classes in Windows Management Instrumentation (WMI), this may result in an open handle to the HKEY_CURRENT_USER registry hive in the WMI provider host (Wmiprvse.exe) at user logoff. This may prevent roaming profiles from being unloaded and saved. These WMI classes are typically enumerated by system management programs to determine system configuration and status.

RESOLUTION

Windows Server 2003

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   ---------------------------------------------------------
   17-Mar-2003  19:52  5.1.2600.1187   203,776  Wmiprvse.exe
   20-Mar-2003  08:47  5.82.2800.1187  533,504  Comctl32.dll
   17-Mar-2003  19:54  6.0.2800.1187   921,600  Comctl32.ocx				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB816880