Two Second Logon Delay Occurs When You Use a Windows 2000-Based Client to Log On to a Windows NT 4.0 Domain (816812)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use a Windows 2000-based client computer to log on to a Windows NT Server 4.0 domain, the logon process is consistently delayed by two seconds.

Entries similar to the following appear in Userenv.log:

USERENV(b8.a0) 10:46:52:720 MyGetUserName:  GetUserNameEx failed with 1355.
USERENV(b8.a0) 10:46:52:720 MyGetUserName:  Retrying call to GetUserNameEx in 1/2 second.
USERENV(b8.a0) 10:46:53:231 MyGetUserName:  GetUserNameEx failed with 1355.
USERENV(b8.a0) 10:46:53:231 MyGetUserName:  Retrying call to GetUserNameEx in 1/2 second.
USERENV(b8.a0) 10:46:53:732 MyGetUserName:  GetUserNameEx failed with 1355.
USERENV(b8.a0) 10:46:53:742 MyGetUserName:  Retrying call to GetUserNameEx in 1/2 second.
USERENV(b8.a0) 10:46:54:253 MyGetUserName:  GetUserNameEx failed with 1355.
USERENV(b8.a0) 10:46:54:253 GetUserGuid: Failed to get user guid with 1355.

CAUSE

This problem occurs because the Windows NT 4.0 DNS server tries to obtain the fully qualified domain name (FQDN) of the user during the logon process of a Windows 2000 client. However, an FQDN for the user account does not exist on the DNS server, and the logon process is unsuccessful in the Windows NT 4.0 domain.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 4.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbprb kbfix kbbug KB816812