Incomplete Installation of Navision Attain Client Causes Problems in the Manage Your Server Wizard and in MMC (816598)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

When you try to install the Navision Attain client from Microsoft Business Solutions, the installation process may not complete successfully, and then you may experience one or both of the following:
  • The Manage Your Server Wizard is not displayed correctly. A Microsoft Internet Explorer script error may be generated.
  • Some components that use Microsoft Management Console (MMC) do not start correctly. For example, when you click Terminal Server Configuration or right-click My Computer, and then you click Manage, you receive the following error message:
    MMC cannot open the file - c:\windows\system32\compmgmt.msc

    This may be because the file does not exist, is not an MMC console, or was created by a later version of MMC. This may also be because you do not have sufficient access rights

CAUSE

This issue occurs because the Navision Attain client (versions 3.10 or 3.6) installs an earlier version of the Msxml3.dll file to a location that is different from the C:\Windows\System32 folder. When you run the regsvr32 command that is described in the "Resolution" section, this reregisters the original (newer) DLL file instead of the (older) DLL that Navision installed.

RESOLUTION

To resolve this issue, reregister the Msxml3.dll file. To do this, follow these steps:
  1. Click Start, click Run, type CMD in the Open box, and then click OK.
  2. Type the following command at the command prompt, where C:\Windows is the folder that Windows is installed in, and then press ENTER:

    regsvr32 C:\Windows\system32\msxml3.dll

When the command completes successfully, you receive the following message:
DllRegisterServer in C:\Windows\system32\msxml3.dll succeeded.

Modification Type:MajorLast Reviewed:3/1/2004
Keywords:kberrmsg kbnofix kbprb KB816598 kbAudITPRO