Pivotal Synchronization with MSOutlook Service Does Not Start After You Upgrade to Windows Server 2003 (816535)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

After you upgrade your Microsoft Windows 2000-based server to Microsoft Windows Server 2003, the Pivotal Synchronization with MSOutlook Service (RSMforMSOutlook.exe), from the Pivotal eRelationship 2000 customer relationship management (CRM) program, does not start. When you try to start the Pivotal Synchronization with MSOutlook Service manually, you may receive the following message: Service failed to start in a timely fashion.

CAUSE

This issue may occur if the client program tries to register a class ID (CLSID) with the OLE component, and is unsuccessful because of new Component Object Model (COM) security features introduced in Windows Server 2003. When the program tries to register an executable (EXE) object with OLE, it calls the CoRegisterClassObject function during startup. This returns a 0x80004015 error. This error corresponds to the following error message:
The class is configured to run as a security ID different from the caller.
When the client program calls the CoRegisterClassObject function before it calls the StartServiceCtrlDispatcher function, it does not register the component because the Windows Server 2003 COM looks at the process ID to verify the service's registration. When the RPCSS service calls the QueryServiceStatusEx function to verify the state of the service, it is notified that the service is in the Service_Stopped state. As a result, it declines the client program's request to register the CLSID.

RESOLUTION

To resolve this issue, contact Pivotal to obtain a possible update for the eRelationship 2000 program. For information about how to contact Pivotal, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/5/2004
Keywords:kbprb kbnofix KB816535