Internet Explorer or Outlook Express quits unexpectedly with an error in Mshtml.dll (816506)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows Server 2003 SP1
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows XP Professional SP2
    • Microsoft Windows XP Home Edition SP2
    • Microsoft Windows XP Professional SP1
    • Microsoft Windows XP Home Edition SP1
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Professional
    • Microsoft Windows NT Server 4.0 SP6
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98
  • Microsoft Internet Explorer (Programming) 6 (SP1)

SYMPTOMS

You may experience any of the following symptoms:
  • After you install the MS03-004: February, 2003, Cumulative Patch for Internet Explorer (Q810847.exe) on a computer that is running Internet Explorer 6 Service Pack 1(SP1), Microsoft Outlook or Microsoft Outlook Express may quit unexpectedly, or you may receive an error message that is similar to the following error message when you type in an e-mail message or you use the Copy and Paste commands to paste text into an e-mail message:
    Outlook Express has encountered a problem and needs to close. We are sorry for the inconvenience.

    If you were in the middle of something, the information you were working on might be lost.

    Restart Outlook Express.

    Please tell Microsoft about this problem

    We have created an error report that you can send to help us improve Outlook Express. We will treat this report as confidential and anonymous.

    To see what data this error report contains, click here.
    When you view the data in the error report, the report contains an error signature that is similar to:
       AppName    AppVer          ModName     ModVer         offset
       ------------------------------------------------------------
       msimn.exe  6.00.2800.1106  mshtml.dll  6.0.2800.1141  varies
    
    Note that this problem may also occur in other programs that use the HTML edit function in Mshtml.dll.
  • Internet Explorer may quit unexpectedly, or you may receive the following error message when you use the services on a Web site:
    Microsoft Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.

    If you were in the middle of something, the information you were working on might be lost.

    Restart Microsoft Internet Explorer.

    Please tell Microsoft about this problem

    We have created an error report that you can send to help us improve Microsoft Internet Explorer. We will treat this report as confidential and anonymous.

    To see what data this error report contains, click here .
    When you view the data in the error report, the report contains an error signature that is similar to:
       AppName       AppVer          ModName     ModVer        offset
       --------------------------------------------------------------
       iexplore.exe  6.00.2800.1106  mshtml.dll  6.0.2800.1141 varies
    
.

CAUSE

The Outlook and Outlook Express problem is caused by a regression error in the Mshtml.dll files that are included with the Internet Explorer 6 SP1 version of the MS03-004: February, 2003, Cumulative Patch for Internet Explorer (Q810847.exe). The Internet Explorer problem occurs if a Web site calls the removeNode method in script code on a cached function pointer on the element style object. In this case, the access violation is more likely to occur as more function pointers on the Web page are dynamically created and then removed with the removeNode method.

RESOLUTION

Windows Server 2003 Service Pack 1 and Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   09-Jun-2005  17:02  6.0.3790.2461  3,109,376  Mshtml.dll

Windows XP Service Pack 2

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Apr-2005  15:49  6.0.2900.2659   3,014,144  Mshtml.dll       

Windows XP SP1, Windows XP, Windows 2000, Windows NT 4.0 SP6, Windows Me, Windows 98 Second Edition, and Windows 98

The following file is available for download from the Microsoft Download Center:
Release Date: March 14, 2003

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Important Install the MS03-015: April, 2003, Cumulative Patch for Internet Explorer (Q813489.exe) before you install Q816506.exe. If you do not install Q813489.exe before you install Q816506.exe, you receive the following error message when you try to install 813489.exe:
Microsoft Internet Explorer Update
This update requires Internet Explorer 6 SP1 to be installed.
For additional information about the MS03-015: April, 2003, Cumulative Patch for Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:

813489 MS03-015: April, 2003, Cumulative Patch for Internet Explorer

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   07-Mar-2003  20:44  6.00.2800.1173  2,683,392  Mshtml.dll
Note This update replaces the Q814834.exe hotfix that was previously available from Microsoft Product Support Services.

STATUS

Microsoft has confirmed that this is a problem in Internet Explorer 6 SP1.

MORE INFORMATION

For additional information about the Q810847.exe and Q813489.exe cumulative patches for Internet Explorer , click the following article numbers to view the articles in the Microsoft Knowledge Base:

810847 MS03-004: February, 2003, Cumulative Patch for Internet Explorer

813489 MS03-015: April, 2003, Cumulative Patch for Internet Explorer


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug KB816506