Slow Performance When CMS Retrieves Group Information from the Active Directory Server (816444)



The information in this article applies to:

  • Microsoft Content Management Server 2001

SYMPTOMS

When Microsoft Content Management Server (MCMS) processes a request, you may notice long delays in the response time of the MCMS server.

CAUSE

When it processes a request, MCMS enters a critical section while it extracts group information from the Active Directory server. If the group information to be retrieved is very large (for example, if it includes users who belong to hundreds of groups), this critical section holds up all the other threads. This in turn affects the MCMS server's response time.

RESOLUTION

This fix modifies the way MCMS retrieves information from Active Directory so that bandwidth is used more efficiently.

Note Generally, the usual way of retrieving information is sufficient. Note that this fix does not make Active Directory or the network respond any faster. It only makes MCMS more efficient.

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Content Management Server 2001 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size    File name
   -----------------------------------------------------
   12-Mar-2003  23:15  4.1.1118.0  78,336  Aeusrmgr.dll     
   19-Jun-2002  20:29  4.0.1381.4  65,600  Cmsupdate.exe    
   11-Mar-2003  02:07               1,556  Update.inf

				
NOTE: Because of file dependencies, this update requires Microsoft Content Management Server 2001 Service Release Package 2 (SRP2).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbfix kbContentMgtServ2001preSP2fix kbbug KB816444