System attendant stops responding when you run Mailbox Manager (816378)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you run Mailbox Manager, the system attendant (Mad.exe) may stop responding and may create a stack dump that is similar to the following stack dump:

ChildEBP RetAddr Args to Child 0c7cb9f8 00454ccd 8004010f 0b901580 00000000 mad!
CStr::strcpy+0x3b 0c7cbf98 004550cf 0c7ccbd4 0c7ccbd4 0b901580 mad!
ScWalkMessages+0x23a 0c7cc294 00455264 0c7ccbd4 0c7ccbd4 0b901580 mad!
ScWalkSubFolders+0x9d 0c7cc598 00455601 0c7ccbd4 0c7ccbd4 0000000c mad!
ScWalkSubFolders+0x232 0c7ccc0c 004509ae 0c7cd770 00000000 0c7cef7c mad!
ScMailboxCleanup+0x1e2 0c7cf95c 00450c6c 00000000 0c7cfc80 0c7cfc5c mad!
CMailboxCleanImpl::ScProcessRecipient+0x247

CAUSE

This problem occurs when Mailbox Manager encounters an object that the PR_MESSAGE_CLASS property does not exist on.

RESOLUTION

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size       File name      Platform
-----------------------------------------------------------------------
13-Mar-2003  21:18  6.0.6437.0         69,632  Ccmproxy.dll   X86
13-Mar-2003  21:18  6.0.6437.0      2,109,440  Cdoexm.dll     X86
13-Mar-2003  21:17  6.0.6437.0      8,466,432  Exadmin.dll
13-Mar-2003  21:18  6.0.6437.0      1,867,776  Exmgmt.exe     X86
13-Mar-2003  21:18  6.0.6437.0         73,728  Inproxy.dll    X86
13-Mar-2003  21:19  6.0.6437.0      2,969,600  Mad.exe        X86
13-Mar-2003  21:17  6.0.6437.0      4,648,960  Maildsmx.dll
13-Mar-2003  21:19  6.0.6437.0         77,824  Pcproxy.dll
13-Mar-2003  21:19  6.0.6437.0         94,208  X400prox.dll   

Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbExchange2000preSP4fix kbBug KB816378