SYMPTOMS
After you install Windows 2000 Service Pack 3 (SP3), you may receive a "Windows File Protection" error message and the following data may be logged in the event logs:
The protected system file Nddeapir.exe was not restored to its original, valid version because the Windows File Protection restoration process was cancelled by user interaction, user name is Administrator. The file version of the bad file is 5.0.2195.3655.
The protected system file Winver.exe was not restored to its original, valid version because the Windows File Protection restoration process was canceled by user interaction, user name is Administrator. The file version of the bad file is 5.0.2195.4454.
Note To view the event logs, click
Start, point to
Programs, point to
Administrative Tools, and
then click
Event Viewer.
CAUSE
This problem occurs if you install the fixes that are described in the following articles before you install Windows 2000 SP3:
311401 Windows 2000 Security Rollup Package 1 (SRP 1), January 2002
298012 MS01-041: Malformed RPC Request Can Cause Service Problems
When you install Windows 2000 SP3, newer file versions of the Nddeapir.exe file and the Winver.exe file that were installed by these fixes may be replaced with older files.
RESOLUTION
Service Pack Information
To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
Hotfix Information
A supported fix is now available
from Microsoft, but it is only intended to correct the problem that is
described in this article. Apply it only to computers that are experiencing
this specific problem. This fix may receive additional testing. Therefore, if
you are not severely affected by this problem, Microsoft recommends that you
wait for the next Windows 2000 service pack that contains this hotfix.
To
resolve this problem immediately, contact Microsoft Product Support Services to
obtain the fix. For a complete list of Microsoft Product Support Services phone
numbers and information about support costs, visit the following Microsoft Web
site:
NOTE: In special cases, charges that are ordinarily incurred for
support calls may be canceled if a Microsoft Support Professional determines
that a specific update will resolve your problem. The typical support costs
will apply to additional support questions and issues that do not qualify for
the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------
31-Jan-2003 21:03 5.0.2195.6661 4,880 Nddeapir.exe
05-Dec-2002 18:17 5.0.2195.6622 4,368 Winver.exe