FIX: Windows Media Player 9 Series Prompts User for Credentials with NTLM Authenticated Proxy (816089)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows 98 Second Edition
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition

SYMPTOMS

When a user tries to connect to external content through an authenticated proxy server, the user may receive a prompt in the Windows Media Player 9 Series. When the user types the credentials, the user can connect to the external content without error.

CAUSE

Because the proxy server is located in the local intranet zone, the Player is expected to send credentials to the proxy automatically. In some cases, the Player does not correctly determine whether the proxy or the external site is prompting for authentication. This fix updates the Player so that it automatically sends NTLM credentials when the proxy is detected to be in the local intranet zone.

Note In some instances, a prompt is expected in the Player. In these instances, the user will receive a prompt dialog box even with this fix.

RESOLUTION

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia9-KB816089-x86-ENU.exe package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The hotfix version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   12-Mar-2003  23:21  9.0.0.3002  982,016  Wmnetmgr.dll     

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:8/4/2004
Keywords:kbdownload kbfix KB816089 kbAudDeveloper kbAudEndUser kbAudITPRO kbAudOEM