SYMPTOMS
On a Microsoft Windows XP Professional-based computer that has Microsoft Client Service for NetWare installed, when you try to open a file on a mapped, shared folder on a Novell 4.11 server, the file may not open, and you may receive the following error message:
This file could not be found
You can open the file when you start the program that created the file that you want to open, click
File, click
Open, and then search for the file on the mapped share. You can also open the file if you use Novell's client service instead of Microsoft Client Service for NetWare.
CAUSE
This problem may occur if you have a combination of long folder names and short folder names (8.3 format) in the path of the shared file.
For example, the file may be in the following location:
\\Computer_Name\Share_Name\Long_Folder_Name\Short_Name\Shared_Folder\file.ext
The problem occurs if you map drive
x: to the following share:
\\Computer_Name\Share_Name\Long_Folder_Name
After this point, the path is in the 8.3 folder name format. As a result, the wrong NetWare Core Protocol (NCP) call retrieves the file. When the call reaches the server,
you receive an error message because the whole path of the file includes a long folder name and is not in the 8.3 folder name format.
RESOLUTION
Service pack information
To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
-----------------------------------------------------
06-Mar-2003 15:29 5.1.2600.1181 156,544 Nwrdr.sys